How do I disable logging from showing up in the admin panel?


Hi all,

How can I disable the logging warnings from showing up in the admin panel, or just plane disable it


This has already been discussed extensively both here and on GitHub. There is currently no configuration setting available to disable the warning or reset the counter.

The warning will disappear after seven days, or if you delete or rotate the log file, it will disappear immediately. However, as soon as new warnings or errors appear in the logs, the warning in the admim panel will re-appear as well.

Ok Thank you for letting me know.

Didn’t realize that it was an issue, no wonder no matter what I did to my config file, nothing was working

Well, the warning itself, if it is an issue at all, is only a cosmetic one.

However, should you keep getting new error messages in the log, you probably need to address them, not only to make the warning disappear, but also because they might indicate actual issues with your instance :wink:

1 Like

My current workaround is to disable the logreader app. Yes, this makes the logs inaccessible in the web UI, but I can also check the nextcloud.log file myself if there is an issue.

It sounds like there is an issue. :slight_smile:

What are the constant errors you’re getting?