How can I get SSH access to my rpi3 Nextcloud Box?

I’ve got a Nextcloud installation running on a Nextcloud Box containing a Raspberry Pi 3.

I installed it using this image: https://download.nextcloud.com/server/images/ubuntu-core-16-armhf-rpi3-installer-20170329.img.

I used a browser to set up an admin account and create a user. However, I don’t know how to get SSH access.

I have a Ubuntu One account and think I understand I need to somehow make a connection between my Nextcloud Box and that account. However, I don’t currently have a clue how to proceed. Is there documentation on how to proceed in this scenario?

When using a pi2, SSH access was easy. To connect for the first time I could enter ubuntu as both default user name and default password. If I try this on a pi3-based system, I get access denied.

I’m hoping that I can use the installation I have already, rather than have to scrap that and start again, installing Ubuntu Core 16 first and then installing Nextcloud on that, which I think will be a significantly more complex process than what I’ve done so far: use a pre-built image including Ubuntu Core 16 and Nextcloud.

Agree, Pi2 procedure was quite simple and Pi3 is a headache…what make the dev team believe this is “out of the box experience”??

Not really, it’ll take a little longer to setup but it isn’t complex vs setting up a traditional server.
That said, if you were to build from scratch I’d suggest the older method with a full ubuntu/debian server as you get far more control.

SSH in the newest is a pain as it require(s/d) registering a key with Ubuntu as far as I recall. They were working on that.

may be someone can make a simple step by step video??

Hello…

Did we get anywhere with this…?

I have just installed my Nextcloud box using a pi2 but stuck a pi3 in and reinstalled using the official image… Nextcloud is up and working but of course I want to secure it… I too have tried withour success to SSH into the wretched box using login/password ubuntu/ubuntu but get access denied…

Does anyone have a fix for this.

Del

Did you follow the manual: https://github.com/nextcloud/nextcloud-snap/wiki/How-to-connect-to-the-Nextcloud-Box-with-SSH ?

Since RPi3 ready image the procedure changed as stated above. In case provide some more information which way you went and which step you failed.

I moved to the ownyourbits version…simple and works

Same here… So easy… I found the whole SSH thing with the ‘official’ release a real pain…Sorry DEVS…

The only hurdle I need to get over is outside access, other than that highly recommneded…

Del

Hi,
same with me.
I made the transition from Pi2 to Pi3 some month ago successfully, but with no access to my system with SSH.
Since it was running nicely I thought it OK. I assumed there is a fault on my side not permitting me my system access. Then there came a power failure and my router got a new IP-address.
Now i needed access to the system to add the new IP to the list of trusted domains. NO CHANCE.
So I decided today that i had to rebuild my Nextcloud Box system from scratch.
That’s what i did.
At the end of the installation (OOBE is the euphemism for this badly documented procedure) it tells me: "default.user@address.de can connect remotely to this device via SSH:
ssh ubuntuaccountuser@192.168.X.XXX."
At the end of the day and after much reading and googling i do not find any hint on how to do this. I have installed and used “SSH Cryptonaut” but to no avail.
frustrated but optimistic
Thanks for help

Hello,

I have a nextcloud box with a raspberry pi2 and I am trying the ubuntu-core image. I too could not log in.

I am trying the information from the guide posted but I have a question

Where do I find information regarding:

The ​ brand​ of the device. This is provided to you by the entity that created the Core system.
The ​ model ​ of the device. This is also provided to you by the entity that created the Core system.

I don’t remember noticing anything like that when I bought it last year.

I tried searching for this but couldn’t find anything.

I have the “vamilla” (?) nextcloud box from WD and used a ~2 yr old raspberrypi 2 that I have in case that helps with the supposed values for brand and model.

the guide seems to be a bit… quirky at times. some ppl got stuck with it. especially with a rp2 model b (or such).
afaik all of them installed the nextcloudpi-image which is pretty well maintained by @nachoparker and some more guys.
https://ownyourbits.com/2017/02/13/nextcloud-ready-raspberry-pi-image/
so i suggest: give it a try and i’m pretty sure that you’ll like it

2 Likes

Thanks a lot, I ll try it.

If your still having issues I suggest you install Rasbian using NOOBS installer and then apt-get apache, php and modules.

Pop in the setup_nextcloud.php then restart and browse to mypi/setup_nextcloud.php and let it set itself up.

You may need to chown to www-data:www-data and chmod 755 but I expect it will work without it.

Never used the nextcloud image myself but used the standard stretch img with an “ssh” file on the boot partition loads of times and never had issues

I tried the official NextcloudPi at first, and for me the problem wasn’t the Nextcloud stuff (works without problems) but the buggy third-party tools (especially wicd-curses for the wifi configuration). The wifi connection just didn’t connect via wicd-curses.
I was able to edit the respective config files for the wifi configuration manually via command line, but I think for user who don’t want to configure such things manually, or first of all having to find out what and where to configure it manually, it might be a bit of a burden.

Meanwhile I installed a plain Rasbian (Stretch) now and put everything else (Nextcloud, Solr, Mysql) on Docker for ARM, it works very well, including remote ssh access. First I had it on RPI2, now it runs on RPi3 without problems so far.

well done! though i’d like to have @nachoparker looking at your comment from above.

as far as i know there’s a new installing wizard for first timers. haven’t tried it yet but could be worth a try.

there are always more ways to come to a working solution than just one or two. so glad that you manage to find your own working way. :slight_smile:

I had already reported the things I found, but unfortunately it’s out of the Nextcloud scope. @nachoparker already looked into it / replied.

oh. well ya. if it’s an external problem…

good boy. whereas i myself wasn’t aware that he was already looking into it. but he’s a great guy and so it’s not surprising that he’s always aware of the probs.

hey @mathiasconradt! I just didn’t recognize you in the picture before! xD

I couldn’t reproduce your problems. Every time I test a new image I connect through wifi for convenience, so I wonder what happened in your case. In any case, wicd-curses is not ideal, but it’s the best option I know for a headless setup.

I started porting Arch’s wifi-menu , but it is not as featureful. Also wicd it is not available in the web interface. In any case, it’s added for convenience, and because it is not in the web interface it is considered a bit more ‘advanced’, and for basic users I recommend just pluging in the ethernet.

Hi @nachoparker, I have no idea what’s wrong with wicd-curses. I have no problems with the wifi configuration anywhere else. wicd-curses finds the wifi network, but just doesn’t connect.

And when I edit the config files (/etc/wpa_supplicant/wpa_supplicant.conf and /etc/network/interfaces) manually, everything is stable and works fine.

Interesting nobody has reported that before. I guess the way to go would be to check if wicd outputs supplicant logs somewhere.

If somebody else is seeing this, please let me know!