How can I change read/write permissions for CalDAVs in DAVx5?

Dear all,

I have a problem with some of my calendars using DAVx5. After setting up my account and syncing it, it shows this symbol for two out of my three CalDAV calendars which I interpret to mean that I have read-only permissions for them. (It looks like a dash inside a circle.) I have attached a screen shot that depicts this situation.

The first calendar is from Nextcloud’s Deck app. I can edit Deck boards without a problem in the browser and they do get synced to my phone but I cannot edit anything on the phone and make those changes sync with the cloud. I suspect that the dash-in-circle symbol means that I have read-only permission. (I’m not worried about the second calendar because those just follow from the “important dates” of the contacts in my address book; so no need to manually edit it.) The third calendar, which is my main personal calendar, gets synced as expected.

  1. Does the dash-in-circle symbol indeed mean that I only have read permissions? DAVx5 unfortunately does not provide a “permissions” section for the entries in this view to verify my assumption.
  2. Assuming that I indeed have a permissions problem, what can I do to grant read/write permissions for these CalDAVs?

Thanks and best,

I think it works as designed at the moment, which means that there is no two-way synchronization for Deck. The same applies for birthdays of contacts, which is automatically filled by taking the birthday information from your contacts.

Thanks, j-ed, for your reply. If this is expected behavior, how then do people use Deck on their mobile phones?

I have tried this app for Nextcloud Deck from F-Droid that supposedly can sync changes both from mobile to cloud and vice versa. (The issues section on that GitHub page shows examples of people solving syncing problems. Just not mine. :wink:) But it did not work in my case, because, as I presume, I am facing said permission problems.

I have also tried jtx Board and, again, I can only see my Deck boards in the cloud but find myself unable to change anything about them.