Hmmm...can’t reach this page

After entering in setup information and clicking continue (or finish or whatever the button is), NextCloud does something then presents me with a page that says “Hmmm…can’t reach this page”. The Apache log states “AH01797: client denied by server configuration: /var/www/html/nextcloud/data/htaccesstest.txt”.

The best I can come up with is something todo with the htaccess file but it is identical to a working NextCould copy on another machine that I am trying to move away from.

NextCloud does do something as it creates the config.php file and I see the information that I entered in it. However, when I close the browser nd go back to the NextCloud Webpage, it is as if it doesn’t recognize the config.php file and asks me to enter all the information again. If I do, it tells me the user already exists. So it has to be reading the config.php file and/or connecting to the DB.

WordPress, YouPHPTube and other web apps work.

<<Here’s my setup>>
Ubuntu 18.04
mysql Ver 14.14 Distrib 5.7.29, for Linux (x86_64) using EditLine wrapper
PHP 7.2
Apache 2.4

I have all the files owned by the apache user (www-data) and all of the files are set to 777 while I try to figure this out.

Attached are my apache2.conf files and the vhost nextcloud.conf

Tearing my hair out here. Thanks in advance.

<<nextcloud.conf VHost file>>
<VirtualHost *:80>
<Directory “/var/www/html/nextcloud”>
Options Indexes FollowSymLinks MultiViews Includes
AllowOverride All
Require all granted
Satisfy any
Allow from all

Options +FollowSymlinks

AllowOverride All

Require all granted

Dav off

SetEnv HOME /var/www/html/nextcloud

SetEnv HTTP_HOME /var/www/html/nextcloud

ServerName ServerAlias DocumentRoot "/var/www/html/nextcloud"


Global configuration

#ServerRoot “/etc/apache2”
#Mutex file:${APACHE_LOCK_DIR} default

DefaultRuntimeDir ${APACHE_RUN_DIR}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/.load
IncludeOptional mods-enabled/
Include ports.conf

Options FollowSymLinks AllowOverride None Require all denied

<Directory /usr/share>
AllowOverride None
Require all granted

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

AccessFileName .htaccess

<FilesMatch “^.ht”>
Require all denied

LogFormat “%v:%p %h %l %u %t “%r” %>s %O “%{Referer}i” “%{User-Agent}i”” vhost_combined
LogFormat “%h %l %u %t “%r” %>s %O “%{Referer}i” “%{User-Agent}i”” combined
LogFormat “%h %l %u %t “%r” %>s %O” common
LogFormat “%{Referer}i -> %U” referer
LogFormat “%{User-agent}i” agent
IncludeOptional conf-enabled/.conf
IncludeOptional sites-enabled/

LoadModule rewrite_module modules/

<Directory /var/www/html/nextcloud/>
Satisfy Any

I played around with some apache and php settings and got NextCloud to refresh the setup page and not give me the Hmmm error. However, it never moves beyond the setup page and gives me an erorr when I try to configure it again stating the user already exists.

I setup owncloud just fine. Apache configured etc. Then I wiped the Owncloud out and put Nextcloud into the directory that Owncloud was in. I didn’t change any apache configurations. When I tried to set up.

It appears that no matter where I try to install it, NextCkoud can not access it’s data folder, despite apache owning it and the permissions being set to 777. The Appcahe log shows the following when I refresh the setup page.

[Thu Mar 26 22:58:10.151149 2020] [access_compat:error] [pid 21971] [client] AH01797: client denied by server configuration: /var/www/html/owncloud/data/htaccesstest.txt

The only thing that I can gleam online is that there is a permission problem somewhere. Again, the file system is owned by apache and is set to 777, and OwnCLoud functions just fine in the same directories (in fact all other apache served sites function fine).


Normaly .htaccess is useed. Please search “htaccesstest”

grep -R /etc htaccesstest
grep -R /var/www/html htaccesstest

Post output

Beat myself trying ot figure this out. Couldn’t figure out what config files to change and changed a lot and finally got several web apps all messed up. So, I just wiped the machine and started over. Working ok. I hate this option as I m nut sure I learned anything.

Close this (or maybe I can and just don’t know how).