Help with format old sd card for new setup

I have now already 2 sd cards and i want to install nextcloud again but i can not format the cards any more.
There is nextcloud on it but i want to format them because these clouds versions crash after i run them.
When i try to format with ubuntu 16 on the pi3 i get:

ERROR formatting disk
error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark,0)

This is my second sd card all is block is have try on my pc but wont work either

How can i get these cards running again? I mean to make them clean

Did you try to google it? For example this is one possible solution to use Gparted instead:

Yoo thanks m8 for the quick information and link.

I will try it and hope it works ill let you know


Nope nothing works :cry:
I have install ubuntu on a pc to try the program but nothing change.
If i unmount, if i format no errors but when i put the card in the pi3 the program is still there
Put the card back in ubuntu gparted nothing is change

It’s unbelievable

Try to erase SD manually. E.g. if you SD card is sdc:

sudo dd if=/dev/zero of=/dev/sdc

Otherwise it could be that SD card is somehow in read-only mode or brocken.

Both cards are so far as i can see in read only mode because with windows when i try to format it say card is protected put protection mode off
But i can not get it off

They can not be broken nextcloud startup on both cards

Did you try something like this under Windows?

  • Connect ’ Read Only ’ storage device such as SD card, USB, external hard drive etc with PC;
  • Open Command Prompt by typing: command in Search tab, right-click Command Prompt run as administrator.
  • Type: diskpart and hit Enter;
  • Type: list disk and hit Enter;
  • Type: select disk 0 and hit Enter; ( 0 shall be the drive letter of your read-only hard drive/USB/SD card etc.)
  • Type: attributes disk clear readonly and hit Enter;
  • Type: exit and hit Enter to finish the process.

Or this:

Sorry for the late reaction but its a little bit hot to sit behind the pc
But i have tried all you tips and I’m sorry to say noting works :cry:

So i have throw it in the garbage and gonna use new ones.
But for me it is not right that i use it after some time and then
it broke the sd card or make it read only even a expensive one from samsung and a sandisk.

But i want to thank you for you’re time for me and give me a lot of explanations to try and repair these cards.
see you around and till the next-cloud-time


1 Like

I hope you checked the switch first:

As far i know the Pi3 has a micro-sd slot and the micro card has no manual lock
And yes my adapters are unlock but i have micro-sd readers so no adapter needed

But thank you for the tip


I have had similar experiences with microSD cards on the Raspberry PI, although with other applications (web server). What I generally see is that after a couple of weeks the system can’t access the hard disk, in casu the microSD card. Ping etc work because that software is cached in RAM, but I can’t log into the system.
A fiend much clever that me on this matter has explained that it probably is the meta information on the card itself that has been clobbered beyond repair.
My solution - which I have to recommend to you - is to discard the SD card in question and get a new one:-(

Exact the same problem here
After some time the cart wont work 100%
Yes i did buy a new card but thls is the third cart
Let see how long this one work
Btw i have a ssd with usb adapter as external harddrive 128gb

How about to have a look on log2ram to decrease amount of writes on SD. Also this would be helpful [SOLVED] Log2ram full because logs too big.
Set MariaDB parameters to make writes each e.g. 30 Seconds or similar. But this will not really help, only give a bit more time… Drive DB based apps on SD cards is per definition is not good idea.