Help test S3 Versioning integration!

Robin just released a beta of our S3 versioning back-end. This uses the native versioning in S3 as Nextcloud versions, pretty neat! Testing and feedback are very welcome. Find the app here:


i tried:

curl -s | /bin/bash
git clone --branch s3primary s3primary
cd  s3primary
./nextdocker.yml -e "nextcloud_server_fqdn=<my-test-domain> ssl_cert_email=<my-email> aws_s3_key=<aws-key> aws_s3_secret=<aws-secret>"

that works fine.

but when i tried to install the app as well i got an error message:

TASK [nextcloud_config : install {{ }} app] ***********************************************************************************************
Saturday 28 September 2019  21:50:44 +0000 (0:00:00.275)       0:03:11.261 ****
ok: [localhost] => (item={u'state': u'disable', u'name': u'survey_client'})
ok: [localhost] => (item={u'state': u'disable', u'name': u'firstrunwizard'})
ok: [localhost] => (item={u'state': u'enable', u'name': u'admin_audit'})
ok: [localhost] => (item={u'state': u'enable', u'name': u'files_pdfviewer'})
failed: [localhost] (item={u'state': u'enable', u'name': u'files_versions_s3'}) => changed=true
  ansible_loop_var: item
  cmd: docker exec --user www-data nextcloud php occ app:install files_versions_s3
  delta: '0:00:02.501207'
  end: '2019-09-28 21:50:48.265445'
    name: files_versions_s3
    state: enable
  msg: non-zero return code
  rc: 1
  start: '2019-09-28 21:50:45.764238'
  stderr: ''
  stderr_lines: <omitted>
  stdout: 'Error: Could not download app files_versions_s3'
  stdout_lines: <omitted>

is there a way to automated that step as well?

p.s.: the integration of s3 as primary storage in my playbook is also new and experimental. if someone want’s to help testing that. i’m open for MRs and feedback. thanks.