[Help][Onlyoffice]Error while downloading the document file to be converted


  • Nextcloud: 26, running from nextcloud-aio, work properly behind nginx reverse proxy
  • Onlyoffice-Documentserver: deploy on a different machine from nextcloud following offical guidance: linux-yum installation
  • Both the Nextcloud and Onlyoffice-DS has enabled the SSL using Let’s Encrypt

What I have done

  • I have tried a lot way to solve this problem but failed
    • I set onlyoffice’s local.json’s ‘header’ in AuthorizationJwt or Authorization
    • I tried all the options that I can configured in nextcloud’s onlyoffice panel
  • I can also use the Onlyoffice-DS’s example completely


  • I guess it’s not the problem of onlyoffice-ds but nextcloud configuration, which because i got this log from onlyoffice-ds’s converter out.log:
  • And I have tried access the test url using wget, resulting the same reaction
  • Here is the Nextcloud’s log

Pls! Any one gives me a guide, thanks a lot!

Sorry forgetting the http rather https result:

:rofl:I have to say. I’m really a fool.

I shut the nginx(for reverse proxy) down for applying ssl certificate using certbot. However, I forgot to run the nginx later.

Maybe you are wondering why I not found it a long time. It’s cause I set the domain to a LAN IP in my hosts in order not allow the webDAV goes the Internet otherwise it costs my traffic fees.

After I run the nginx, it’s encounter a 403 Forbidden. But I’m luck, it was caused by “Download empty without jwt”.
If you also stuck by this, you can check if you set onlyoffice’s local.json all token.enable to true and the header in value “Authorization” rather than “AuthorizationJwt”