Help me to configure nextcloud vm

Hello,

I tried the configuration from VMware … I had some problems.
So I bought the Hyper-V version of Hanssonit.se .

Having never been able to configure properly … I finally returned to VMware.
I have no idea if the configuration of good or not currently, I am a regular at windows … linux is my first experience (for life).
So I go around in circles without result for 3 days.

I can access nextcloud from this address: 192.168.1.36.
My domain name does not join this IP address …
locally if i try to access nextcloud i get this error:
Access from an untrusted domain.

Although I read the documentation … I have no idea how to fix it all …
In short, what is super simple for some is an impossible mission for me.
To say that I thought I could set up nextcloud for my party, I must admit that the gift I wanted to make is bitter at the moment …

In short, if a charitable soul could help me … guide me … or take control at a distance (whatever), I want my nextcloud to be functional one day … and here I am at the edge of the agony.

1 Like

Are you comfortable with Ubuntu at all? If so, install via Docker or snap are both pretty easy.

We had this here:

really not, i was never able to complete the installation. so i reinstall back W10 pro.
My first idea was to put a clean and fresh install of ubuntu, but just the install break my head… #noobian here powered by windows

the bad thing is…i understand nothing in that.
I use MS environment for too long and we cannot install nextcloud server directly on windows.
So i feel like to be at my first day in class.

I’ve tried :

sudo docker exec --user www-data nextcloud php occ overwrite.cli.url --value=https://disque.fiasko.ca

And the result was:

sudo: docker: command not found

As i said i use the Nextcloud VM - by T&M Hansson IT on vmware (actually).
I had no idea how to change things to make possible to reach my nextcloud.

sorry. in a non-docker environment it should be:

sudo -u www-data php /var/www/html/occ overwrite.cli.url --value=https://disque.fiasko.ca

where /var/www/html/occ depends on your installation. could be also /var/www/html/nextcloud/occ. in case of doubt find /var -name occ or locate occ.

to fix the trusted domain problem:
sudo -u www-data php /var/www/html/occ config:system:set trusted_domains 2 --value=disque.fiasko.ca

where the “2” depends on the number of entries already in your config.php file. the config.php is in the folder config in the folder where you found occ.

or you run sudo -u www-data php /var/www/html/occ config:system:get trusted_domains

I restarted all the process and now i can access nc in local.
In external like disque.fiasko.ca give me a 522 error by cloudflare. i try to investigate that now…

During onlyoffice installation i received this error (just now)

There is an issue with cloudflare. It won’t work. You can find issues about this here in the forum and in the nextcloud documentation online.

bah nothing work at all (except in local using 192.168.1.XXX).

Using my domain name the page could not be reach.
At the end of configuration system told me to change login.
I changed it and till this time i cannot login in the terminal…

little update: nextcloud run well in local.
My ISP block ports 80 and 443.
So i subscribed to no-ip.
my domain name --> public IP:51290 --> Router DMZ (192.168.1.51) --> Nextcloud VM internal IP (192.168.1.100).
ports 80, 443, 51290 open in W10 firewall.
if i do a séarch for ports open…all are listed “closed or blocked”…
Whàt can i do to resolve this last problem?

I think there is still some confusion here… you should have no need to open ports on a Windows 10 client.

Please explain your setup in detail.

that means: “we don’t want you to run servers at home.” :wink:


in your case you need “DNS-01 challenges” to get a letsencrypt cert.

first: ask google if that’s possible with no-ip.com.

daniel (@enoch85) has implemented this method in his scripts. so you my ask him who to set it up correctly.

you may experiment a bit on the command line with

certbot certonly --manual --manual-public-ip-logging-ok --preferred-challenges dns  --rsa-key-size 4096 --renew-by-default --no-eff-email --agree-tos --uir --hsts --server https://acme-v02.api.letsencrypt.org/directory -d disque.fiasko.ca
# or 
certbot certonly --manual --manual-public-ip-logging-ok --preferred-challenges dns  --rsa-key-size 4096 --renew-by-default --no-eff-email --agree-tos --uir --hsts --server https://acme-v02.api.letsencrypt.org/directory -d office.fiasko.ca

and check the certbot manual how dns-01 challenge is working.

if you got that working, you have to change the apache config so that apache/nextcloud is no longer listening on port 443 but on 51290.

Funny fact…everything work except only office.
funny fact #2: trying to reach your server when vmware is closed is a bad idea…

So, my paid hyper-V vm will never be used…

Now i have to find a way to take control of terminal.
Since they ask to change the username and password, i cant access anymore the terminal.

https://docs.hanssonit.se/s/W6fMouPiqQz3_Mog/virtual-machines-vm/d/W6fMquPiqQz3_Moi/nextcloud-vm-first-setup-instructions :slight_smile:

Thanks, everything work with VMware !

1 Like