Help, I can not install nextcloud

#1

How can I generate a new and clean installation? I have followed several tutorials and not a single one has worked for me, I do not know what is happening.
I have zorin os that is based on ubuntu 16.04. Also use win 10 with the sub system ubunto but nothing
What is your advice?

#2

So give us a quit more informations:

Which Verion of nextcloud?
Which web server have you installed? (Apache, nginx)
Which database have you installed? (MySQl, MariaDB)
Which PHP version have you installed? (7.X)
Any error messages?

#3

I can give you my notice of an installation in VirtualBox running ubuntu server 18.04 LTS:
please note that it is partly written in german for the explanations
The endofline is after some number of lines eliminated. When i edit it, all end of lines are correct …
If you give email, i can send you txt file of installation, that worked with 16.0.1 and resulted in “Installation has no warnings and errors” …

Setup Nextcloud

sudo su
apt-get install htop
apt-get install mc
apt-get install apache2 mariadb-server libapache2-mod-php7.2
apt-get install mariadb-client
apt-get install php7.2-gd php7.2-json php7.2-mysql php7.2-curl php7.2-mbstring
apt-get install php7.2-imagick php7.2-intl php7.2-zip php7.2-dom php7.2-XMLWriter
apt-get install php7.2-XMLReader php7.2-libxml php7.2-SimpleXML
wget https://download.nextcloud.com/server/releases/nextcloud-16.0.1.tar.bz2
tar -xjf nextcloud-16.0.1.tar.bz2
cp -r nextcloud /var/www
nano /etc/apache2/sites-available/nextcloud.conf
#Inhalt:
#---------------------------------------
Alias /nextcloud “/var/www/nextcloud/”

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud

#-----------------------------------------

a2ensite nextcloud.conf
a2enmod rewrite
a2enmod headers
a2enmod env
a2enmod dir
a2enmod mime
a2enmod ssl
a2ensite default-ssl
chown -R www-data:www-data /var/www/nextcloud/
service apache2 reload
service apache2 restart
mysql_secure_installation
#bei erster Installation Passwortabfrage mit ENTER bestätigen
#set root password - y
#new password: xxxxx
#reenter new password: xxxx
#remove anonymous users - y
#disallow root login remotely - y
#remove test database and access to it - y
#reload privilege tables now - y
mysql -uroot -p

create user ‘root2’@‘localhost’ identified by ‘yourmariadbpassword’;
CREATE DATABASE IF NOT EXISTS nextcloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci;
grant all on . to root2@localhost identified by ‘yourmariadbpassword’ with grant option;
#GRANT ALL PRIVILEGES on nextcloud.* to ‘root2’@‘localhost’;
flush privileges;
exit
#Meine Installation erfolgt in Virtualbox bei Sata0 64GByte System und
#Sata1 500GByte Nextclouddaten
mkdir /media/nextclouddata
mkfs.ext4 /dev/sdb
mount /dev/sdb /media/nextclouddata
nano /etc/fstab
#anfügen von:
#---------------------------------------------------
/dev/sdb /media/nextclouddata ext4 defaults 0 2
#---------------------------------------------------
chown -R www-data:www-data /media/nextclouddata/
nano /etc/php/7.2/apache2/php.ini
#einfügen von: (;am Beginn der Zeile entfernen und Werte
#bei Bedarf korrigieren)
#-------------------------------------
opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
#--------------------------------------
apt-get install php-apcu
service apache2 restart

Einrichtung über Webfrontend starten

#admin
#passwort angeben
#/media/nextclouddata
#root2
#passwort mariadb-datenbank (wie selbst vergeben)
#nextcloud
#localhost (ist bereits vorgegeben)

erst dann mit nächster Zeile weitermachen

nano /var/www/nextcloud/config/config.php
#folgende Zeile als letztes vor der Abschlußklammer einfügen:
#---------------------------------------
‘memcache.local’ => ‘\OC\Memcache\APCu’,
#ganz oben unter 0 =>

1 => ‘yourowndomain’,

2 => ‘localhost’,

3 => ‘127.0.0.1’,

4 => ‘192.168.0.48’,

5 => ‘192.168.0.22’,

#sonst ist Nextcloud nicht von außen erreichbar, beliebig erweiterbar
#---------------------------------------
service apache2 restart
cd /var/www/nextcloud
sudo -u www-data php occ db:convert-filecache-bigint
nano /etc/apache2/sites-available/default-ssl.conf

Korrigieren von Serveradmin - your@emailadress

Korrigieren von Document Root - /var/www/nextcloud

einfügen der folgenden Zeilen nach DocumentRoot

#---------------------------------------
ServerName yourowndomain

Header always set Strict-Transport-Security “max-age=15552000; includeSubDomains”

#----------------------------------------
service apache2 restart
nano /etc/mysql/my.cnf

einfügen der folgenden Zeilen am Ende der Datei

#----------------------------------------
[mysqld]
innodb_large_prefix=true
innodb_file_format=barracuda
innodb_file_per_table=1
#-----------------------------------------
mysql
ALTER DATABASE nextcloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci;
flush privileges;
exit
service mariadb restart
sudo -u www-data php occ config:system:set mysql.utf8mb4 --type boolean --value=“true”
sudo -u www-data php occ maintenance:repair

check, ob alle Einträge auf Barracuda stehen:

mariadb
SELECT NAME, SPACE, FILE_FORMAT FROM INFORMATION_SCHEMA.INNODB_SYS_TABLES WHERE NAME like “nextcloud%”;
service mariadb restart
sudo -u www-data php occ db:add-missing-indices
nano /etc/php/7.2/apache2/php.ini
#Suche nach memory_limit
#den Wert auf 1024 setzen
service apache2 restart

Installation LetsEncrypt Zertifikat

apt-get install software-properties-common
add-apt-repository universe
add-apt-repository ppa:certbot/certbot
apt-get update
apt-get install certbot python-certbot-apache
certbot --apache
service apache2 restart
#Einrichtung cronjob für nextcloud
crontab -u www-data -e
#1 für nano wählen
#Einfügen:
#----------------------------------------------------------
*/5 * * * * php-cli -f /var/www/nextcloud/cron.php
#----------------------------------------------------------
#Einrichtung cronjob für letsencrypt-Aktualisierung
crontab -e
#Einfügen von
#----------------------------------------------------------
40 3 * * 0 letsencrypt renew
#----------------------------------------------------------