Help for Configuration needed after update fails

After updating from V18 to V19 I had cache problems. Today from V19.0.1 to 19.0.2 the system can not reboot anymore.

Message: Update in process.

Since 8 hours.

I am bad in Ubuntu. Can I pay someone to update that proper?


Changed category for you. Hope someone will contact you soon.

you should try and learn. How bad are you ?

Do you know command line shell?
can you navigate trough your directories by shell
do you know sudo?

go to your NC INSTALL DIR

cd /var/www/nextcloud

Then try to upgrade manually

sudo -u www-data php occ upgrade
1 Like

Sounds like you used the updater from the web admin console? I just upgraded from 19.0.1 to 19.0.2 today and the webpage will stick on update in process depending on if you kept it in maintenance mode or not and if you are using LDAP or not. The online administrator manual does describe this situation if I am reading you correctly, which is what I used. If you follow @Vincent_Stans two shell commands you should be back up pronto.

Hi both. There are so many issues. Not only to “run” the update. Also to have access to config folder, occ filesscan:all does not work anymore and a lot error informations on admin overview page:

  1. not possible to execute cron job via CLI
  • X-Frame-Options HTTP header not set SAMEORIGIN
    Strict-Transport Security error
  • No memory cache configured
  • "Referrer-Policy HTTP not set

But I see config with write access, there is cache and I dont know what the HTTPS problem is.

So I asked someone now to check. He solved the update. But errors are still on Overview page. He said, its a problem of NextCloud, not on my server. I have absolut no idea where to start fixing. To many ways and to many different errors.

So I hope on a fix for that on next NC update. For a “chat” it will take hours to fix that with my current Linux-Experience.

Thank you for the try for help and the commands of occ upgrade. But he will not find occ. Even if its on system. I need to write full occ path but why? So already at basics, it takes hours for me to go through. I will try it on next time when upgrade fails.
Thank your very much.

Current errorlist

Oke commands to do no harm can be done

sudo apt-get install php-apcu 

Add a line to your /var/www/nextcloud/config/config.php put the complete line somewhere after a ,

‘memcache.local’ => ‘\OC\Memcache\APCu’,

This will solve your no memory cache

next run

sudo -u www-data php -f /var/www/nextcloud/cron.php

check in you web interface at basic settings and see if cron has just been executed.
or give the error from the command line

Next what webserver are you using ?

Let us know how it worked out

1 Like

I setup the line /var/www/nextcloud/config/config.php in config.php for cache issue.

php-apcu is already the newest version (5.1.18+4.0.11-1+ubuntu18.04.1+deb.sury.o         rg+1).
The following packages were automatically installed and are no longer required:
  libhiredis0.13 libluajit-5.1-2 libluajit-5.1-common php-igbinary

I did the entry on config.php.
The path for nextcloud is different (goes over /media/nextclouddata/) and there is config.php. But there is no cron.php file. No cron.php file available. I executed the command sudo -u www-data php…cron.php as explained but nothing happends. After 5 minutes waiting, I pressed CTRL+C to stop the command. No error, nothing.

edit: cron.php is now available after switching in frontend website between AJAX and Cron. Great!! Thank you also for that.

It seems that the “no cache” issue has been gone now!! Thanks for that.

When using ‘service nginx status’, I get response: Active (running)

Hi at all. I fixed now all bugs in case of your forum. Thank you for that

Additional other x-frame-options-http-header

1 Like