[Help] CardDAV Client fails due to 404 response on PROPFIND request w/ BusyContacts

carddav

#1

Dear community,

I have set up a NextCloud Server on a new server which is supposed to replace our famillies current OwnCloud installation.
Installation was done according to [NextCloud 14 Admin Manual]
For the Apache site configuration file I took the one as base which I am currently using for OwnCloud as this is working very well with all clients.

Calendar and Contacts Apps are enabled.

System Environment:

Server

  • Ubuntu 18.04 LTS
  • Apache 2.4.29
  • PHP 7.2.7
  • Maria DB 10.1
  • NextCloud 14.0.3
  • SSL Certificate by Let’s Encrypt

Client

  • MacOS 10.14 Mojave
  • BusyContacts 1.3.0

The Web frontend seems to run fine, no errors or warnings in the Admins overview page. Tough, performing the following steps, syncing any address book fails:

  • Create NextCloud user account (mickey) using the Web frontend
  • Log in as the user (mickey)
  • Import Address Book from Client using the NextCloud web frontend
  • Addresses are displayed and are editable in web frontend
  • Create CardDav account for user mickey in BusyContacts

-> Sync over CardDav account fails in BusyContacts with the following message:

<d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns">
    <s:exception>Sabre\DAV\Exception\NotFound</s:exception>
    <s:message>Principal with name remote.php not found</s:message>
</d:error>

Output of your Nextcloud log in Admin > Logging:

-> No log message during time frame of test

The Apache server access log shows the following lines whenever BusyContacts try to sync:

78.42.108.24 - - [29/Oct/2018:08:51:43 +0100] "PROPFIND /.well-known/carddav HTTP/1.1" 301 5565 "-" "BusyContacts-1.3.0"
78.42.108.24 - mickey [29/Oct/2018:08:51:43 +0100] "PROPFIND /remote.php/dav/ HTTP/1.1" 207 1952 "-" "BusyContacts-1.3.0"
78.42.108.24 - mickey [29/Oct/2018:08:51:54 +0100] "PROPFIND /remote.php/dav/ HTTP/1.1" 207 2299 "-" "BusyContacts-1.3.0"
78.42.108.24 - mickey [29/Oct/2018:08:52:07 +0100] "REPORT /remote.php/dav/principals/users//remote.php/dav/principals/groups//remote.php/dav/principals/calendar-resources//remote.php/dav/principals/calendar-rooms/ HTTP/1.1" 404 1613 "-" "BusyContacts-1.3.0"

Since there is no log entry in the NextCloud log file but an 404 error in Apache, is it correct to assume that I have a configuration issue in Apache?
Any ideas where I would have to search?
Which log files would you need to support me here?

Thanks a lot for your help!

Kind regards,
Michael


#2

Old Owncloud Account was created in an older version of BusyContacts. NextCloud I tried after updating to BusyContacts 1.3.0 - there it produced the error described above.

After deleting BusyContacts and installing it again, I was able to create a working NextCloud account :grimacing:

Several hours of time wasted …:angry: - anyhow, at least now it works.


#3

Awesome!
Thanks for your feedback. Glad to hear that it is now working!!


#4