Having problems getting off the ground

I need some help getting my inital setup working.

I have my cloudflare DNS setup to point to my NPM. I have a few other services running through NPM so I think it’s all working ok.

I followed the instructions for NPM. In from HTTP out to the internal IP of NextCloud on port 11000

HTTP - - 11000

Internaly I can connect to NC, but of course I can’t complete it and I can’t connect from the world. So something isn’t right.

My internal NPM address is BTW.

Here is the docker compose file. Any help would be great.



name: nextcloud_aio_mastercontainer



image: nextcloud/all-in-one:latest

restart: always

container_name: nextcloud-aio-mastercontainer


- nextcloud_aio_mastercontainer:/mnt/docker-aio-config

- /var/run/docker.sock:/var/run/docker.sock:ro


#- 80:80



environment: # Is needed when using any of the options below




I brought my post over here because I hoped to get some more varied responses. The trouble shooting didn’t help me.

If you are sure that you’ve configured everything correctly then you can simply skip the domain validation and check if you get any further as advised in the last step of the troubleshooting section :wink:

That’s the problem. I’m not sure that I have.
When I try to reach it from the world it fails. But internaly it works. I don’t know what I have wrong ether.

Unfortunately you didnt provide enough info in order to help you. So I recommend the debugging steps.

What other information do you need. I will try to pull what I can.

I need to see your npm docker-compose and a screenshot of the npm side where you put in e.g. http://localhost:11000

I can do that.
NPM compose file.
image: ‘jc21/nginx-proxy-manager:latest’
container_name: NPM
restart: unless-stopped
- # Public HTTP Port
- # Public HTTPS Port
- # Admin Web Port
- /var/data:/data
- /var/letsencrypt:/etc/letsencrypt

Screenshot 2023-04-19 060138

Thanks! So do I understand correctly that npm runs on a server with the ip-address and aio on a different server with ip-address

In that case I would try to set APACHE_IP_BINDING to and disable the Cloudflare proxy feature if it should be active. (Btw point 3 and 7 of all-in-one/reverse-proxy.md at main · nextcloud/all-in-one · GitHub)

Do you still get an error then when trying to submit your domain in the aio interface afterwarss? And if yes which one?

Thx I’ll try that. Also to be really clear they are 2 separate containers on the same host. I’m not sure if that matters or not.

So where do these ip-addresses and come from when the containers are on the same host?

Can you simply try to put the private ip-address of the host into NPM instead of Does it work then (still with apache_ip_binding set to

I haven’t been able to try yet. But I will try to try when I get home from work tonight.
These IPs are alias’s on the host. I have several containers that want the same port facing the network. So I created network aliases then bound the containers to different IP’s as needed.

That seems to have worked! Thank you for all your time and bearing with my slow learning curve.