Hauptmen├╝punkte funktionieren nicht korrekt nach Update auf 16.0.4

Hi zusammen, nach Update von Nextcloud Version 16.0.3 auf 16.0.4 lassen sich die Hauptmen├╝punkte ┬╗Aktivit├Ąt┬ź, ┬╗Galerie┬ź und ┬╗Deck┬ź zwar anklicken (die richtige URL steht im Link korrekt), es wird dann aber immer die Seite ┬╗Dateien┬ź abgezeigt. Gibt man den Link beispielsweise f├╝r die App ┬╗Deck┬ź manuell in die Adresszeile ein, erscheint das Deck. Was ist da los? Hat jemand Ideen?


Hi,

bei mir funktioniert es noch normal. Kannst du mal deinen Browser-Cache leeren, in die Browser-Console nach Fehlermeldungen schauen oder als letztes noch die Logs von Webserver und Nextcloud auf Fehler durchsuchen?

Das komplette Leeren des Browser-Caches bringt leider nichts. Das war auch meine erste Idee. Danach erscheinen weiterhin die Fehlermeldung:

┬╗Refused to execute a script because its hash, its nonce, or ÔÇśunsafe-inlineÔÇÖ does not appear in the script-src directive of the Content Security Policy.┬ź

20

Daneben erscheinen noch Warnmeldungen wie u.a.: ┬╗The escapeHTML library is deprecated! It will be removed in nextcloud 19.┬ź (siehe auch Screenshots)


Das Nextcloud-Log enth├Ąlt offensichtlich keine Auff├Ąlligkeiten oder gar Fehlermeldungen nach dem Update. Gleiches bei den Webserver-Errorlogs.

Im Nextcloud-Log stehen nur diese Eintr├Ąge nach dem Update:

|Level|App|Message||Time|
|Info|updater|\OC\Updater::resetLogLevel: Reset log level to Warning(2)||2019-08-28T11:57:43+0200|
|Info|updater|\OC\Updater::maintenanceDisabled: Turned off maintenance mode||2019-08-28T11:57:43+0200|
|Info|updater|\OC\Updater::updateEnd: Update successful||2019-08-28T11:57:43+0200|
|Info|updater|\OC\Updater::finishedCheckCodeIntegrity: Finished code integrity check||2019-08-28T11:57:43+0200|
|Info|updater|\OC\Updater::startCheckCodeIntegrity: Starting code integrity checkÔÇŽ||2019-08-28T11:57:37+0200|
|Info|updater|\OC\Repair::step: Repair step: Cleanup cypress files from viewer app||2019-08-28T11:57:28+0200|
|Info|updater|\OC\Repair::info: Repair info: No need to remove link shares.||2019-08-28T11:57:28+0200|

In der Zwischenzeit habe ich herausbekommen, da├č der Fehler nicht beim Firefox Mac Version 68.0.2 (64-Bit) vorkommt ÔÇô zumindest oberfl├Ąchlich. Mit ihm l├Ąuft Nextcloud ohne Probleme. Der Fehler taucht bei mir beim Safari Version 11.1.2 (aktuelle Version) auf.

Das selbe passiert beim MS Edge, wobei der Edge aber bereits bei der Installation von Nextcloud als inkompatibel erkannt und daher von dessen Verwendung abgeraten wird.

Problem ist gel├Âst. Jetzt funktioniert ┬╗Deck┬ź wieder, nachdem ich das Update auf Nextcloud 17 durchgef├╝hrt habe. Danke f├╝r Eure Kommentare.