Guide/HowTo install NC18 on a Vserv from Strato with Ubuntu 18.04 LTS with Plesk Onyx?

Hi there!

I am looking for a step-by-step-guide to make a clean install of NC18 on a Vserv from Strato(German hoster) running Ubuntu 18.04 LTS with Plesk Onyx 18, Apache2, MySQL?

I find a lot how-to´s for earlier NC-versions running debian or centOS and so on, or with & without Plesk, or running NGINX instead of Apache or MariaDB instead of MySQL - but not for my exact situation.

That causes, that I am not able (or its hard) to really address the “problems” in Nextcloud, with e.g. OPCache, imagick and so on because PLESK hast its own ways to do things - and I am not sure when using the console and when better using PLESK.

The only guide coming “near” my situation is the following - but with Debian9:

Any hints or a functioning step-by-step-guide for those “strato-vserver-users” with the above os-situation would be much appreciated.

Hi newnoob,

Ubuntu is a derivative of Debian, it uses Debian as a base, and adds it’s own software/look. So, the guide you linked, should work for you on Ubuntu as well as it did for the creator of this guide on his Debian 9 machine.

You should be safe to use this guide :+1:

Delete Plesk, delete Ubuntu, install Debian Buster 10. :wink:

Ok i think it works with Ubuntu, too.

I love to be able to use a config-GUI which is intuitive for me. Debian-stand-alone means hours of hours navigating trough and editing files, commands and so on in the console “by hand” - which is time consuming for a GUI/APP-guy like me.

I get totally that console-nerds would always argue for the opposite. The thing is, that I like to USE the applications I install - like nextcloud - but I am not the person who works on a shell 24/7 - that is where a GUI comes in handy, when it is just every now and then you have to look “under the hood”.

What a pity! Unix/Linux console changes not in last 30 years. You must it study only once.

I have a server with Debian 9 and Plesk installed and was able to install Nextcloud without any issues. Most of the Apache/PHP stuff can and should be done in Plesk. If Plesk is involved and you change stuff manually in any config, the chances are high, that these manual changes will be gone, the next time you update a sub-/domain within the Plesk panel because Plesk is going to rotate the configs and create new ones with the information saved in Plesk.

Whether you use MySQL or MariaDB doesn’t make a lot of difference to Plesk, since you just create a database in Plesk and can access it right away via the shipped phpMyAdmin.

Yes. But if all works command line is easy. You can copy and paste the obove installation instruction and it works.

Just follow the How to from Cry-Sys and you should be fine :+1: If you should encounter any problems during the process, you can always ask and people on this forum will help :+1:

1 Like

Thnx. But the guide causes a couple of errors in PLESK.

Whatsoever I got NC18 up and running - still with some issues:

Fx:
it says that the php-module imagick is missing - I have installed it via apt (imagemagick) but not solved it yet.

Do you get the error in NC or in Plesk?

Can you add a new file to your NC18 root folder and call it phpinfo.php with the following content:

<?php

phpinfo();

Now go to your-nextcloud-domain.tld/phpinfo.php in your browser and check if you can find anything related to imagick

EDIT:

You can also check within Plesk, if the module is active:

(German) - Tools & Einstellungen > PHP-Einstellungen

Click on the PHP version you are using for your NC host and check if imagick is ticked.

It can´t be ticked, because it does not appear in “Tools & Einstellungen > PHP-Einstellungen”.

Do you get the error in NC or in Plesk?

The only other thing I could think of, is that you installed imagemagick via apt but PHP still does not know anything about the module.

Can you SSH into your server and go to /opt/plesk/php/x.x/etc/php.d/ and look if you have a file called imagick.ini?

x.x needs to be changed to the PHP version you are using with your NC host.

This imagick.ini needs to be present and the content should look like:

; Enable imagick extension module
extension=imagick.so

If this is the case, you could also restart your Apache like so:

sudo systemctl restart apache2

This will restart your Apache server and cause it to reload all included modules.

OK - it seams that Ubuntu 18.04 LTS per default installs PHP 7.2 while PLESK Obsidian V.18.0.25 expects PHP 7.3 or 7.4 - because there are just directories installed in /opt/plesk/php/x.x/etc/php.d/ with “inis” for PHP 7.3 and [EDIT]7.4 - but not for [EDIT]7.2 - and just these contain the ‘imagick.ini’. - [EDIT]there is no directory for PHP7.2 … o.O

So what should I to do from here? Add a unofficial repository to install PHP 7.3 or 7.4 - or copy and paste all the “inis” in directory and rename it “7.2”?

OK - Plesk comes with its own PHP 7.4 - now that I´ve activated it inside PLESK and for the NC-instance the imagick-error is disappeared inside NC18. (solved!)

Going on with the “PHP-Memory-Cache” issue… :confused:

So… continuing this nightmare…

Now trying to compile redis by following the guide - which always ends with errors after ‘make test’:

"
Logged warnings (pid 13952):
Killing still running Redis server 14062
(none)

Killing still running Redis server 14098
I/O error reading reply
while executing
“$r set [expr rand()] [expr rand()]”
(procedure “gen_write_load” line 6)
invoked from within
“gen_write_load [lindex $argv 0] [lindex $argv 1] [lindex $argv 2]”
(file “tests/helpers/gen_write_load.tcl” line 15)I/O error reading reply
while executing
“$r set [expr rand()] [expr rand()]”
(procedure “gen_write_load” line 6)
invoked from within
“gen_write_load [lindex $argv 0] [lindex $argv 1] [lindex $argv 2]”
(file “tests/helpers/gen_write_load.tcl” line 15)
I/O error reading reply
while executing
“$r set [expr rand()] [expr rand()]”
(procedure “gen_write_load” line 6)
invoked from within
“gen_write_load [lindex $argv 0] [lindex $argv 1] [lindex $argv 2]”
(file “tests/helpers/gen_write_load.tcl” line 15)
I/O error reading reply
while executing
“$r set [expr rand()] [expr rand()]”
(procedure “gen_write_load” line 6)
invoked from within
“gen_write_load [lindex $argv 0] [lindex $argv 1] [lindex $argv 2]”
(file “tests/helpers/gen_write_load.tcl” line 15)

I/O error reading reply
while executing
“$r set [expr rand()] [expr rand()]”
(procedure “gen_write_load” line 6)
invoked from within
“gen_write_load [lindex $argv 0] [lindex $argv 1] [lindex $argv 2]”
(file “tests/helpers/gen_write_load.tcl” line 15)
Killing still running Redis server 14105
Killing still running Redis server 14116
Killing still running Redis server 14123
Makefile:271: recipe for target ‘test’ failed
make[1]: *** [test] Error 1
make[1]: Verzeichnis „/tmp/redis-cache/redis-stable/src“ wird verlassen
Makefile:6: recipe for target ‘test’ failed
make: *** [test] Error 2"

Me personally, I’m using APCu instead of redis or memcached.

Here is a How To in German on how to install APCu with Plesk: https://markus-blog.de/index.php/2018/04/23/ubuntu-16-04-lts-installation-apcu-object-cache-und-einbindung-in-nextcloud-unter-plesk/

Ignore the fact that he is using 16.04, this should work on 18.04 as well

1 Like

Super - APCu seams to work now. Thnx!

Now there is just this 4-byte thing … but is it really essential if it´s just for emote-icons?

You mean the utf8mb4 conversion of your database tables/columns? The initial trigger of this were the emojis, since only utf8mb4 was able to hold them.

I mean you don’t have to do it but it doesn’t hurt to do it either, since we never know what comes next and it removes one more warning from your admin page. :wink: It’s always good to be prepared for future uses.

Found this question/answer in German, this should give you a rough idea of what and how to do it: https://qastack.com.de/dba/8239/how-to-easily-convert-utf8-tables-to-utf8mb4-in-mysql-5-5