Guest Accounts force two-factor authentication

I create a guest account for sharing. All goes well. Guest user receives email, creates a password and then logs in. After logging in, guest is shown this message:

Two-factor authentication is enforced but has not been configured on your account. Contact your admin for assistance.

Is there a setting somewhere to disable two factor auth for guest accounts?

Thank you!

I think the easiest way to find this out is checking your current 2FA configuration. Below of the "Enforce two-factor authentication! button you will find options to include or exclude specific user groups:

Thank you for taking the time to help. I turned off the setting to enforce 2 factor for all users. I think that should do it.