Groupfolders.app NotPermittedException error doesn't stop

The following error always occurs every hour.

  [core] Error: OCP\Files\NotPermittedException:  at <<closure>>

  0. /MY-NEXTCLOUD/nc/apps/groupfolders/lib/Versions/GroupVersionsExpireManager.php line 71
     OC\Files\Node\File->delete()
  1. /MY-NEXTCLOUD/nc/apps/groupfolders/lib/Versions/GroupVersionsExpireManager.php line 57
     OCA\GroupFolders\Versions\GroupVersionsExpireManager->expireFolder({id: 6,mount_poi ... e})
  2. /MY-NEXTCLOUD/nc/apps/groupfolders/lib/BackgroundJob/ExpireGroupVersions.php line 40
     OCA\GroupFolders\Versions\GroupVersionsExpireManager->expireAll()
  3. /MY-NEXTCLOUD/nc/lib/private/BackgroundJob/Job.php line 61
     OCA\GroupFolders\BackgroundJob\ExpireGroupVersions->run(null)
  4. /MY-NEXTCLOUD/nc/lib/private/BackgroundJob/TimedJob.php line 55
     OC\BackgroundJob\Job->execute(OC\BackgroundJob\JobList {}, OC\Log {})
  5. /MY-NEXTCLOUD/nc/cron.php line 124
     OC\BackgroundJob\TimedJob->execute(OC\BackgroundJob\JobList {}, OC\Log {})

Is this completely my environment-only error?
Is there a solution?


Nextcloud 17.0.0(This is confirmed from NC15)
PHP 7.3.11, nginx 1.16.1, Groupfolders 5.0.4

1 Like

Same here with GF 4.1.4 / NC 16.0.5.1 on Debian 10, PHP 7.3 and Apache 2.4

looooong list of messages and growing

:crazy_face:

Same here, same error. My error log is quite large with this.

NC 16.0.6
php 7.3
ubuntu 18.04

1 Like

FYI

I believe we have the same issue here, NC 17.0.2 and all apps on most recent stable version. Any ideas?

The logs look like this (path was anonymized by me):

OCP\Files\NotPermittedException:
/usr/www/users/xxxxx/xxxxx/apps/groupfolders/lib/Versions/GroupVersionsExpireManager.php - line 71:
OC\Files\Node\File->delete()
/usr/www/users/xxxxx/xxxxx/apps/groupfolders/lib/Versions/GroupVersionsExpireManager.php - line 57:
OCA\GroupFolders\Versions\GroupVersionsExpireManager->expireFolder({ id: 6,moun … e})
/usr/www/users/xxxxx/xxxxx/apps/groupfolders/lib/BackgroundJob/ExpireGroupVersions.php - line 40:
OCA\GroupFolders\Versions\GroupVersionsExpireManager->expireAll()
/usr/www/users/xxxxx/xxxxx/lib/private/BackgroundJob/Job.php - line 61:
OCA\GroupFolders\BackgroundJob\ExpireGroupVersions->run(null)
/usr/www/users/xxxxx/xxxxx/lib/private/BackgroundJob/TimedJob.php - line 55:
OC\BackgroundJob\Job->execute(OC\BackgroundJob\JobList {}, OC\Log {})
/usr/www/users/xxxxx/xxxxx/cron.php - line 124:
OC\BackgroundJob\TimedJob->execute(OC\BackgroundJob\JobList {}, OC\Log {})

I’ve been running into this issue for quite some time, and it’s definitely happening once an hour. Is this not noticed by the developers, or is it too difficult to fix?

@zoo3: I was at the Nextcloud meetup in Berlin yesterday in order to discuss it with someone. But we had so much other talks that we did not reach to this topic. But it’s definitely very annoying. It happens to only one of our cloud installations, and we have no idea why.

I also have a problem that the execution result of “occ groupfolders:permissions” command is not displayed properly. *Only the table header is displayed.

I want to completely uninstall Groupfolders once. For example, when I remove the Groupfolders app using the NC UI, MariaDB still has GF. tables.
What can I remove to completely uninstall Groupfolders?

I have the same error on NC 18.01 and GroupFolders 6.0.1. Also curious where this comes from and how to fix. Thanks.