Google-Drive External Files (0.2.8). App suspected of involvement in my "PHP Fatal error:" (Sev-1)

My Nextcloud 13 system appears to be broken. Here is an example:

sudo -u www-data php /var/www/nextcloud/occ status
[sudo] password for sysadmin:
PHP Fatal error: Interface ‘OCA\Files_External\Lib\Config\IBackendProvider’ not found in /var/www/nextcloud/apps/files_external_gdrive/lib/AppInfo/Application.php on line 32

Previously I had a fully working Nextcloud 13.0.2.1 system running, tested and customised on new hardware with Ubuntu 18.04, PHP 7.2, Apache2 2.4.29, MariaDB 10.1. Load testing went brilliantly. Nextcloud was ready to “Rock-n-Roll” and go live with family+friends…
Then I went and broke it…! (Not intentionally, I might add)

I had installed the “files_external_gdrive” app (version 0.2.8) with the intention of trying it out, but so far haven’t had the opportunity. I had already experimented with hooking up the “files_external” app to my NAS box but the SMB/CIFS connection always gave me a “frustrating” red-box ( FAIL! ). FTP was a green-box but very, very slow. My disappointment with not establishing a viable linkage to my NAS kit is what made me then decide to "disable” the official “files_external” app using the Web GUI. It was shortly after this that Nextcloud came crashing down and I later dug out this bad news from the log…

[Thu May 31 13:54:52.088060 2018] [php7:error] [pid 12937] [client 127.0.0.1:55508] PHP Fatal error: Interface ‘OCA\Files_External\Lib\Config\IBackendProvider’ not found in /var/www/nextcloud/apps/files_external_gdrive/lib/AppInfo/Application.php on line 32

The statement in the “files_external_gdrive” app causing the fatal PHP error is below:
/**

  • @package OCA\Files_external_gdrive\AppInfo
    */
    class Application extends App implements IBackendProvider {

    public function __construct(array $urlParams = array()) {
    parent::__construct(‘files_external_gdrive’, $urlParams);
    }

Thankfully my trusty ownCloud 8.1 is still operational, so I can leave the Nextcloud 13 project unaltered for a few days… It would be good to find out what has happened. Especially so I don’t do it again… If a developer could give me guidance, I would appreciate it. Due to OCC being busted, it means a more skillful diagnostic+repair will be needed.
Note: I regret that in the knowledge world of “LAMP”, I am still stuck on the letter L. :blush:
Cheers & à bientôt, Pete

1 Like

Following the advice of @tflidd I deleted the folder of the app (/var/www/nextcloud/apps/files_external_gdrive). My thanks!
For the time being my Nextcloud 13 is back-up and long may it stay that way. :beer: Cheers

5 Likes

Thanks Humbug for having driven the discussion to the resolution of the issue. You saved my day by providing the fix for the very same error on NextCloud 14.0.1. The trouble was related to the fresh activation of the Google Drive app too, which evidently looks like broken and should not be made available any more in the NextCloud Store.

Bye.

The issue has been reported to the application developer on GitHub. Until he updates the app and fix the compatibility problem, would it be possible for the Nextcloud app store curator (or whoever else may be involved in managing the store) to make unuvailable Google-Drive External Files to NextCloud 14 users?

This app killed my NextCloud server too. I had to delete files_external_gdrive folder as suggested above, otherwise I could not disable this app. Issue on the github is closed, but clearly it is not solved in App Store. Either nobody removed broken app from App Store, or the developer did not solve this issue and uploaded another broken version.

I think this app should be removed from NextCloud apps till it will be fixed. A lot of user’s has been affected by this. My NextCloud has been broken by it too.

Just experienced the same issue and COMPLETELY agree!!!
I posted here…

I had this problem too, in Nextcloud 15. However I managed to get things working again, by removing the files_external_gdrive folder, then installing the External Storage Support app, and then re adding the files_external_gdrive app.

I assume it requires the Files External to work, which makes sense, but it isn’t handling things very gracefully when it can’t!

Greetings everyone.
This seems to be an old post. yet, yesterday I updated my nextcloud (on a raspberry pi) to V. 15.05. After that I found the gdrive external files app. I installed it… sure enough I had the same problem reported here.
Very scary issue actually.
Finding this post and the solution was fantastic.

  1. it seems that ever since this problem came up, the app never left the apps list. Clearly is still an issue
  2. the solution to delete /var/www/nextcloud/apps/files_external_gdrive its still a perfect solution and my web gui with all its functionality, came back!

I support the suggestions of many here; the app should maybe be removed or explained well how would that work.
Regards,

As Nev Gibson pointed out, if you enable External Storage Support first, you can then safely install Gdrive.

A yes, I see it now on its website.
I should have look better and
I will give it a try when possible. I think I first will backup the cloud…
Thanks for the heads up

This trap occurred when I wanted to deactivate the Gdrive and OneDrive external apps.

I probably deactivated External Storage Support first and then lost contact with Nextcloud. After reading this post I understood the problem
did - rm -r /var/www/nextcloud/apps/files_external_onedrive
and rm -r var/www/nextcloud/apps/files_external_gdrive

After that Nextcloud worked normally again.