Godaddy subdomain masking not working

#1

I just installed ubuntu + nextcloud 11

I am trying to configure my subdomain (forwarding + masking) but when I am configuring forwarding + masking it is not working, when configuring only forwarding it is working fine.

I contacted the godaddy support and said that it has something to do with the site. Any ideas ?

#2

I imagine that could well be a security feature. CC @LukasReschke

#3

how can I remove it then ?

#4

It’d be far more secure to manage the domain DNS rather than forwarding…

#5

you mean I create an A record with the domain like the below ?

#6

anyone can guide me on how to do domain dns with masking as I only managed to do the domain dns without the masking :S

#7

You just specify an IP for an A type entry. You can put an URL there.

With the iframe, that is prevented by these security settings:
https://docs.nextcloud.com/server/9/admin_manual/configuration_server/harden_server.html#serve-security-related-headers-by-the-web-server

I wouldn’t disable them if you do this differently. If you control the Nextcloud server, you can easily set up a virtual host for this subdomain you are planning to use.

#8

Sorry chap I didn’t see your reply. A … subdomain (or www if you’re not using it for anything else) … IP
That’s an A record and what you need if you have a public static IP. If it’s dynamic you should setup a dynamic dns like duckdns or noip.com and create a cname from your subdomain to the domain name given by the dynamic dns provider.

#9

thanks for your reply when creating the cname I am getting the below, I created the subdomain from godaddy and a ddns from dyndns

#10

I am getting the below error: left it overnight but still

#11

I wouldn’t use WebHop Redirect if you want to use your hostname in sharing URLs. It should be Host with IP address and the dyndns-service should then keep the IP address updated.

#12

but with ipaddress I cannot specify the folder that I have installed nextcloud:

xxx.xxx.xxx.xxx/nextcloud

#13

Normally you do manage this on your webserver, you automatically redirect requests to https://yourhost.com to https://yourhost.com/nextcloud

If you have your own domain, you normally can create as many subdomains as you want. Therefore, I wouldn’t install Nextcloud into a subdirectory (I’m currently planning to move away from the subdirectory) because of the __Host prefix mitigates cookie injection vulnerabilities:

1 Like
#14

If you don’t want it showing /nextcloud at the end then as @tflidd states, configure your webserver to either redirect, or change the webroot directory from /var/www/html/ to /var/www/html/nextcloud

There’s info for setting up vhosts and configs here: