Gnome settings app hangs when trying to connect Nextcloud account

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

I am using the Nextcloud snap

Nextcloud version (eg, 20.0.5): 26.0.4
Operating system and version (eg, Ubuntu 20.04): Fedora 38
Apache or nginx version (eg, Apache 2.4.25): 2.4
PHP version (eg, 7.4): 8.1.20

The issue you are facing:

I am trying to connect my nextcloud to my pc as an online account in Gnome. But, whenever I put in my server url, username, and password, the settings app freezes up and starts to stall. then a minute or so later, a pop up saying that it is not responding appears and says I can wait or force quit. I have tried with both my normal password and an app password. They have the same result.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Install nextcloud as a snap
  2. try to log in on fedora through the gnome settings app

The output of your Nextcloud log in Admin > Logging:

There are no server logs

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = aray (
	'apps_paths' =>
		0 =>
		array (
			'path' => '/snap/nextcloud/current/htdocs/apps',
			'url' => '/apps',
			'writeable' => false,
		1 =>
		array (
			'path' => '/var/snap/nextcloud/current/nextcloud/extra-apps',
			'url' => '/extra-apps',
			'writeable' => true,
	'supportedDatabases' =>
	array (
		0 => 'mysql',
	'memcache.locking' => '\\OC\\Memcache\\Redis',
	'memcache.local' => '\\OC\\Memcache\\Redis',
	'redis' =>
	array (
		'host' => 'tmp/sockets/redis.sock',
		'port' => 0,
	'log_type' => 'file',
	'logfile' => 'var/snap/nextcloud/current/logs/nextcloud.log',
	'logfilemode' => 416,
	'instanceid' => '',
	'passwordsalt' => '',
	'secret' => '',
	'trusted_domanins' =>
	array (
		0 => '',
		1 => '',
	'datadirectory' => '/mnt/nextcloud_storage/data',
	'dbtype' => 'mysql',
	'version' => '',
	'overwrite.cli.url' => 'http://localhost',
	'dbname' => 'nextcloud',
	'dbhost' => 'localhost:/tmp/sockets/mysql.sock',
	'dbport' => '',
	'dbtableprefix' => 'oc_',
	'mysql.utf8mb4' => true,
	'dbuser' => 'nextcloud',
	'dbpassword'  => '',
	'installed' => true,
	'maintenance', false,
	'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

wasn't able to find this


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

There were no errors, but here are the warnings if that is useful

    The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

    You have not set or verified your email server configuration, yet. Please head over to the Basic settings in order to set them. Afterwards, use the "Send email" button below the form to verify your settings.
    Your installation has no default phone region set. This is required to validate phone numbers in the profile settings without a country code. To allow numbers without a country code, please add "default_phone_region" with the respective ISO 3166-1 code ↗ of the region to your config file.
    The PHP module "imagick" is not enabled although the theming app is. For favicon generation to work correctly, you need to install and enable this module.

I managed to fix it. Apparently the integration with Gnome requires the server to have a certificate from letsencrypt, and not just a self signed certificate. And that requires you to have a domain name. So, one namecheap purchace later I am up and running

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.