Getting NC 10 to work with Synology Cloud Sync?

Hi folks,

maybe some of you know the Synology Disk Stations Cloud Station. It features a Cloud Sync module, to connect with other cloud services.

As far as I knew, I should have been able to connect it with my (perfectly running) nextcloud 10. So I set up a dedicated account in my Nextcloud and tried to input it in DS / Cloud Sync / WEBDAV, as instructed by synology to get Cloud Sync to work with owncloud.

However, it doesn´t seem to work and reports a failed authentification - any ideas, anybody?


What URL did you use? Only the host or with …/remote.php/dav…?

SUBDOMAIN.DOMAIN.TLD, which works so far great for my clients, web browser etc…

I also tried the https://SUBDOMAIn.DOMAIN.TLD/remote.php/webdav/ variant, but i couldnt even input that line in synology…

Can you try a different webdav client to make sure that the webdav-interface created by NC is working properly (e.g. WinSCP) or run a litmus test.

Sorry, unable to do so…

Then check with the synology community for tricks on their OS.

@lex didi you a find a solution to your problem? I’m currently facing the same issue with NC11.
The WebDAV works as I can connect from other clients correctly.

No, problem actually got never resolved on my end, despite trying everything which was mentioned here.

Am a little bit sad, because it seems in the ende there is no way to really resolve issues.

Did you post a bug report against nextcloud server? I could not find any. I’m pretty sure there will be a solution if we all join forces. And the nextcloud community has been very responsive so far.
Did you contact the Synology support?

I’m following up on this forum post at the Synology forum

I’m still trying to figure out why this does not work with Synology Cloud Sync.

One reason might be that the setup of the Cloud Sync does not allow to put the full webdav address ( but only the domain part without the path ( Webdav connections without the path fail (tested with KDE Dolphin).

Is there a way we can make webdav work with nextcloud without the full path?

Oh, stupid me, I got it to work! :smiley: The only problem with the address was actually the trailing slash!



Not very smart of the Synology Cloud Sync setup.
The documentation of Synology can be found here