FullTextSearch and Elasticsearch Errors

NC 19.0.3 upgraded today. Full-Text Search and Elasticsearch installed two weeks ago. Full-Text Search has not worked as of yet, though it did do an index that took more than 24 hours. Still, it doesn’t work as expected, didn’t return files that have searched terms included, except for file names. Following is the message from the Nextcloud log. My question is, should perform the “initial” indexing again or is there a different method I should follow?

[fulltextsearch] Debug: Could not determine if provider with id ‘files’ was properly indexed because the corresponding provider-option could not be found. Make sure the initial indexing process has been completed successfully.

GET /settings/admin/logging
from 192.168.*. by ******** at 2020-09-11T17:46:08+00:00

The following settings are on the Full Text Seach panel:

Search Platform = Elasticsearch
Navigation Icon = Checked
Address of Serverlet = http://localhost:9200
Index = 591cloud_index
Analyzer Tokeniser = standard
Local Files - Checked
External Files - Do not index path nor content (It was set to “Index Path and Content” but changed it and still get the same error)
Group Folders =-Checked
Max File Size = 20
Extract PDF = checked
Extract Office = checked

No other settings are selected or enabled on the page.