Full text search not working for local file contents

Nextcloud version (eg, 12.0.2): 17.0.1
Operating system and version (eg, Ubuntu 17.04): Debian 10.2
Apache or nginx version (eg, Apache 2.4.25): apache2/stable,stable,now 2.4.38-3+deb10u3 amd64 [installed]
PHP version (eg, 7.1): PHP 7.3.11-1~deb10u1 (cli) (built: Oct 26 2019 14:14:18) ( NTS )

The issue you are facing:
Elasticsearch is working, but contents do not seem to be getting indexed.

Is this the first time you’ve seen this error? (Y/N): Yes, never tried Elasticsearch + Full Text Search before

PID 565 still running.


Looks to me like Elasticsearch is working, but no search ever returns content that I know is in a file.

The setup for this was very unclear and there was much trial and error. The nextcloud index is not used. That was from a failed setup attempt.

Edit: Yes I know it is a wide open eleasticsearch instance. I removed readonlyrest during testing. putting it back and using the username in the URL returns the same results.

A search for something that is in an XML file is not found. but the XML file itself is found.


Some triple checking, and a reboot later.

I gave up and deleted the all of the indexes in elastic search and then kicked off a new initial index.

That seems to have worked for the most part. That scan stopped with a fatal error. I’ll make a new post about that.

But the files it had scanned prior to that are now searchable.