Full text search is not picking up changes from INotify on external storage

Nextcloud version: 17.0.3
Operating system and version: Ubuntu 18.04
Apache or nginx version: 2.4.29
PHP version: 7.2

The issue you are facing:

Is this the first time you’ve seen this error? : N

Steps to replicate it:

  1. Install Full text search apps, Elastic search, INotify.
  2. Confirmed that INotify is working by running it with verbose mode and then modifying files in external storage. INotify prints out activity in external files correctly.
  3. Full text search indexing (fulltextsearch:index) seems to run correctly. I had previously indexed all my files and could search for them in NextCloud, but changes to external files are not indexed.
  4. Create and run a service that runs INotify processes for each external storage.
  5. When I run fulltextsearch:live and then make a modification to a file, I do not see any indication in the fulltextsearh:live screen that it picked up the changes and indexed them. I have seen it react to some changes before, but now it just keeps saying “working”. Files are not available in search after modifications.

The output of your Nextcloud log in Admin > Logging:
I’m only seeing stuff related to APCU:

{"reqId":"blGE1TFwW5oZ1nwoYrnk","level":3,"time":"2020-01-31T23:54:49+00:00","remoteAddr":"","user":"Doug","app":"PHP","method":"PROPFIND","url":"/remote.php/dav/files/Doug/WorkTools/KnowBrainer/CommonModules","message":"Module 'apcu' already loaded at Unknown#0","userAgent":"Mozilla/5.0 (Windows) mirall/2.6.2stable-Win64 (build 20191224) (Nextcloud)","version":"","id":"5e34be4a2884f"}

{"reqId":"DUKTUApCJeXBWL3WmmH7","level":1,"time":"2020-01-31T23:45:02+00:00","remoteAddr":"","user":"--","app":"cli","method":"","url":"--","message":"Memcache \\OC\\Memcache\\APCu not available for distributed cache","userAgent":"--","version":"","id":"5e34bd34ba9bc"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'removed',
  'passwordsalt' => 'removed',
  'secret' => 'removed',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '...',
    2 => 'removed',
    3 => '...',
    4 => '...',
  'datadirectory' => '/var/www/owncloud/data',
  'overwrite.cli.url' => 'http://localhost/owncloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => '...',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => '...',
  'dbpassword' => '...',
  'logtimezone' => 'UTC',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0.0,
    'password' => '...',
  'maintenance' => false,
  'updatechecker' => false,
  'theme' => '',
  'loglevel' => 0,
  'mail_smtpmode' => 'smtp',
  'mail_from_address' => '...',
  'mail_domain' => 'gmail.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => 'smtp.gmail.com',
  'mail_smtpport' => '587',
  'mail_smtpname' => '...',
  'mail_smtppassword' => '...',
  'appstore.experimental.enabled' => false,
  'files_external_allow_create_new_local' => 'true',
  'updater.release.channel' => 'stable',
  'mysql.utf8mb4' => true,
  'updater.secret' => '...',

The output of your Apache/nginx/system log in /var/log/____:
The entire log??? How about the latest error:

[Fri Jan 31 18:48:13.889918 2020] [authz_core:error] [pid 24145] [client] AH01630: client denied by server configuration: /var/www/owncloud/data/.ocdata

Thanks for the help!  I would love to get this working.


Bump… Anybody else having this problem? I’d rather stay with nextcloud but need some help to do so. Any insight would be appreciated.

Thanks in advance!

Changed category to full text search in hopes that it gets better visibility. If I could locate the log files for this app I could perhaps debug the problem, but I can’t find any helpful logs. Any pointers would be greatly appreciated.