Fresh Fedora 31 Server NC17 Install, resolving caldav, carddav, memory cache, and OPCache warnings

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 17
Operating system and version (eg, Ubuntu 17.04): Fedora 31 Server
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.41 (Fedora)
PHP version (eg, 7.1): 7.3.12
SQL_: Maria

The issue you are facing:

On a fresh install I’m getting warnings about the following:

  • Your web server is not properly set up to resolve “/.well-known/caldav”
  • Your web server is not properly set up to resolve “/.well-known/carddav”
  • No memory cache has been configured
  • The PHP OPcache is not properly configured

Nextcloud is installed at /var/www/html/nextcloud

I’ve done a lot of digging and read the documentation included on the Overview page.

First up for the resolve issues, my /var/www/html/nextcloud/.htaccess file already has everything listed:

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{HTTP_USER_AGENT} DavClnt
  RewriteRule ^$ /remote.php/webdav/ [L,R=302]
  RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
  RewriteRule ^\.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L]
  RewriteRule ^\.well-known/host-meta\.json /nextcloud/public.php?service=host-meta-json [QSA,L]
  RewriteRule ^\.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L]
  RewriteRule ^\.well-known/nodeinfo /nextcloud/public.php?service=nodeinfo [QSA,L]
  RewriteRule ^\.well-known/carddav /nextcloud/remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/caldav /nextcloud/remote.php/dav/ [R=301,L]
  RewriteRule ^remote/(.*) remote.php [QSA,L]
  RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
  RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation)/.*
  RewriteRule ^(?:\.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

I don’t know why it’s being ignored.

Secondly in regards to the opcache, I only have one php.ini and it is in /etc/ and it doesn’t have opcache.enable anywhere in it, commented or uncommented. It’s all listed in /etc/php.d .

When running php.a and then print_r(opcache_get_configuration()); it says opcache.enable is 1.
But php -i is saying it is disabled for CLI.

Searching for answers points towards php 7.2, so I’m not finding much help there.

And lastly the memory cache, I’ve read

and I guess my main question is does anyone around here know if Jason’s writeup will work with Fedora?

I’ve been re-installing from scratch for over a week now trying to get this up and running. And this is reoccuring with each install when it goes “right.” My apprehension is getting near peak.

Oh, and I guess after installing php-intl Nextcloud is yammering at me for using a fallback implementation. How do I go about resolving that?

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Fresh Install LAMP on Fedora 31
  2. Put Nextcloud at /var/www/html/

The output of your Nextcloud log in Admin > Logging:

Error	PHP	You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => '192.168.1.X',
    1 => '',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,

The output of your Apache/nginx/system log in /var/log/____: