Freigabe-Link - Neue Benutzer/Gruppen können nicht gefunden werden

Hallo zusammen,

Ich habe ein eigenwilliges Problem.
Seit einiger Zeit betreibe ich auf meinem Strato-Root-Server eine Nextcloud-Instanz mit einer SQLite 3 DB und auf PHP 7.0.33.
Aufgrund von Problemen mit der PHP-Installation war ich seit längerem auf der Version 15.x geblieben, ohne zu updaten.

Gestern Abend habe ich sowohl eine neue Gruppe, als auch einen neuen Benutzer angelegt und wollte die Gruppe, die drei Mitglieder hat (zwei alte und den neuen Benutzer), einer Freigabe hinzufügen. Leider konnte ich weder den neuen Benutzer, noch die neue Gruppe in der Suche finden, sehr wohl aber die alten Benutzer.

Da ich vermutete, dass vielleicht etwas mit der Version nicht stimmte, oder die Datenbank vielleicht einen Fehler hatte, habe ich mich an den Schrittweise Umbau begeben.

Mittlerweile lauft die Instanz auf einer MySQL, PHP 7.4.6 und der Nextcloud-Version 18.0.5.
Das Problem hat sich leider jedoch noch nicht gelöst.

Kennt jemand vielleicht diese Problematik und kann mir einen Tipp geben?

Danke und Gruß
Yipie

Update: Mit direkter Manipulation der MySQL-DB kann ich wenigstens den neuen User manuell für die Freigabe eintragen und er erhält auch Zugriff. Bei der Gruppe klappt das Mapping leider nicht.

gibts bei den Einrichtungs- & Sicherheitswarnungen keine ungelösten Konflikte mehr?

Hast du ein von deiner alten NC Datenbank Export durchgeführt? Und sie danach wieder importiert?

Hallo Nanu,

Danke für Deine Frage und sorry für meine späte Antwort.

Ich habe keinerlei manuellen export oder import durchgeführt.
Lediglich nach dem letzten upgrade ein “occ db:convert-type --all-apps mysql nextcloud 127.0.0.1 nextcloud” durchgeführt um auf eine mysql-DB umzustellen, die ich zuvor leer erstellt habe.
Das war dann schlussendlich der letzte Versuch die Probleme in den Griff zu bekommen, hat aber auch nicht wirklich was gebracht.
Leider kann ich nicht im Detail sagen, was die Routine im Hintergrund genau macht. :disappointed:

Gruß
Yipie

Hallo JimmyKater,

Auch Dir Danke für Deine Antwort und sorry, dass ich heute erst antworten kann.

Folgende Meldungen habe ich derzeit noch im System übrig:

  • Der "Strict-Transport-Security“-HTTP-Header ist nicht auf mindestens "15552000“ Sekunden eingestellt. Für mehr Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in den [Sicherheitshinweisen] erläutert ist.
  • Das PHP-OPcache-Modul ist nicht geladen. [Für eine bessere Leistung empfiehlt es sich] das Modul in Ihre PHP-Installation zu laden.

Hierzu muss ich allerdings sagen, dass die Einstellungen für das OPCache-Modul eingespielt sind und phpinfo auch klar das Modul als aktiv anzeigt.
Ebenso habe ich eigentlich die HSTS-Einstellungen sollten aktiv sein, da muss ich aber noch einmal nachsehen, wieso das derzeit scheinbar nicht gezogen wird.

Gruß
Yipie

Auch eingetragen in config/config.php ?
'memcache.local' => '\\OC\\Memcache\\APCu',

Ja, meine config/config.php enthält die folgende Zeilen:

...
'memcache.locking' => '\\OC\\Memcache\\Redis',
'memcache.local' => '\\OC\\Memcache\\APCu',
...

Schau sicherheitshalber, ob die Pakete installiert sind. Welches Betriebssystem nutzt du?

https://packages.debian.org/de/buster/php-apcu

Hab ihr euch schon mal gefragt warum manche \ \ nutzen und andere nur \ :stuck_out_tongue:

Bist du dir sicher das php7.4.6 rennt?
Was sagt den php -version

Und service --status-all

Das kann ne zeitlang dauern bis die abfragen durch sind.

#php7.4 -version
PHP 7.4.6 (cli) (built: May 14 2020 10:02:18) ( NTS )
Copyright © The PHP Group
Zend Engine v3.4.0, Copyright © Zend Technologies
with Zend OPcache v7.4.6, Copyright ©, by Zend Technologies

service --status-all

[ + ] apache-htcacheclean
[ + ] apache2
[ + ] apparmor
[ - ] bind9
[ - ] bootmisc.sh
[ - ] checkfs.sh
[ - ] checkroot-bootclean.sh
[ - ] checkroot.sh
[ + ] cron
[ + ] dovecot
[ - ] fail2ban
[ - ] fetchmail
[ - ] hostname.sh
[ - ] hwclock.sh
[ - ] killprocs
[ - ] kmod
[ ? ] modules_dep.sh
[ - ] mountall-bootclean.sh
[ - ] mountall.sh
[ - ] mountdevsubfs.sh
[ - ] mountkernfs.sh
[ - ] mountnfs-bootclean.sh
[ - ] mountnfs.sh
[ + ] mysql
[ + ] networking
[ - ] ondemand
[ + ] pc-remote
[ + ] php7.0-fpm
[ + ] php7.4-fpm
[ - ] plesk-php55-fpm
[ - ] plesk-php56-fpm
[ - ] plesk-php70-fpm
[ + ] plesk-php74-fpm
[ - ] plymouth
[ - ] plymouth-log
[ + ] postfix
[ + ] procps
[ + ] psa
[ ? ] psa-firewall
[ + ] quota
[ - ] quotarpc
[ + ] rc.local
[ + ] redis-server
[ - ] rsync
[ + ] rsyslog
[ - ] screen-cleanup
[ - ] sendsigs
[ + ] ssh
[ - ] sw-collectd
[ + ] sw-cp-server
[ + ] sw-engine
[ + ] tss3
[ + ] udev
[ - ] umountfs
[ - ] umountnfs.sh
[ - ] umountroot
[ + ] unattended-upgrades
[ + ] urandom
[ - ] uuidd
[ - ] wide-dhcpv6-client
[ + ] xinetd

Ich laufe auf einem “Ubuntu 16.04.6 LTS”

Zusätzlich Auszüge des phpinfo-Laufes:

PHP Version 7.4.7

Server API FPM/FastCGI

Configuration

apcu

APCu Support Enabled
Version 5.1.18
APCu Debugging Disabled
MMAP Support Enabled
MMAP File Mask no value
Serialization Support php
Build Date Jun 7 2020 00:48:25
Directive Local Value Master Value
apc.coredump_unmap Off Off
apc.enable_cli Off Off
apc.enabled On On
apc.entries_hint 4096 4096
apc.gc_ttl 3600 3600
apc.mmap_file_mask no value no value
apc.preload_path no value no value
apc.serializer php php
apc.shm_segments 1 1
apc.shm_size 32M 32M
apc.slam_defense Off Off
apc.smart 0 0
apc.ttl 0 0
apc.use_request_time On On

Zend OPcache

Opcode Caching Up and Running
Optimization Enabled
SHM Cache Enabled
File Cache Disabled
Startup OK
Shared memory model mmap
Cache hits 50006807
Cache misses 1320
Used memory 94275928
Free memory 107050664
Wasted memory 0
Interned Strings Used memory 3472416
Interned Strings Free memory 2818592
Cached scripts 1320
Cached keys 1320
Max keys 16229
OOM restarts 0
Hash keys restarts 0
Manual restarts 0
Directive Local Value Master Value
opcache.blacklist_filename no value no value
opcache.consistency_checks 0 0
opcache.dups_fix Off Off
opcache.enable On On
opcache.enable_cli Off Off
opcache.enable_file_override Off Off
opcache.error_log no value no value
opcache.file_cache no value no value
opcache.file_cache_consistency_checks On On
opcache.file_cache_only Off Off
opcache.file_update_protection 2 2
opcache.force_restart_timeout 180 180
opcache.huge_code_pages Off Off
opcache.interned_strings_buffer 16 16
opcache.lockfile_path /tmp /tmp
opcache.log_verbosity_level 1 1
opcache.max_accelerated_files 10000 10000
opcache.max_file_size 0 0
opcache.max_wasted_percentage 5 5
opcache.memory_consumption 192 192
opcache.opt_debug_level 0 0
opcache.optimization_level 0x7FFEBFFF 0x7FFEBFFF
opcache.preferred_memory_model no value no value
opcache.preload no value no value
opcache.preload_user no value no value
opcache.protect_memory Off Off
opcache.restrict_api no value no value
opcache.revalidate_freq 0 0
opcache.revalidate_path On On
opcache.save_comments On On
opcache.use_cwd On On
opcache.validate_permission On On
opcache.validate_root Off Off
opcache.validate_timestamps Off Off

Hi devnull,

zu diesem Thema scheint es unterschiedlichste Seiten zu geben.
Die erste, die ich gefunden hatte, hatte nunmal die zusätzlichen Escape Characters eingebaut.

Habe eben mal probiert, ob es einen Unterschied bringt, aber zumindest für den Fehler macht es sich nicht bemerkbar.

Ich bin immernoch der Ansicht das es sich um ein Datenbankfehler handelt.
Ach und schalt mal fail2ban ein. :wink:

Zuerst mal ein Backup machen bevor du an deiner Datenbank rumwurstelst :wink:
Dann
sudo -u www-data php occ maintenance:mode --on
und
sudo -u www-data php occ db:convert-filecache-bigint
sudo -u www-data php occ maintenance:mode --off

Und leg mal zum test ein neuen Admin an. Kann sein das es dir da deine rechte zerschossen hat.