Forms update, redirect to Dashboard

Hi all,

i’d like to redirect an issue from our issue-tracker to the support here:
After update, some people complained, their App-Navigation does redirect to the dashboard, instead of opening the forms app. However, i have existing setups (also production setup), that work flawless on exactly that NCserver/app combination.

  • The app in background seems to work, two users reported that existing form-links do still work.
  • Until now, no user reported an error-message on the log.
  • One user reported a working setup after reboot, another reported it working “After a couple of reboots, couple reinstalls of the app, almost a full day
  • I indeed changed something on the routes with the update, to me it seems like some caching problem (which sometimes persists upon restart??:thinking:)
  • The only thing the reports seemed to have in common so far, was an nginx server

As i am no nginx or server expert, nor do i have the resources to provide support on our issue-tracker, i’d like to hand this over here. Maybe some experienced nginx(?)-experts do have an idea how to solve in a quick fashion.

Thank you in advance! :rocket: :wink:
Greets,
Jonas

PS: Once we have an error identified, i’m of course happy to trace and fix that. But currently i honestly have no ansatz or idea of a code-problem, that i could try to fix…

For Reference:
First issue
Second Issue

Reported Server combinations

nginx/1.19.8 (fpm-fcgi)
mysql 10.5.9
PHP 7.4.3
Nextcloud 20.0.8 - 20.0.8.1
Nginx 1.14.2
PHP 7.3.27
Nextcloud 21.0.0.
Ubuntu Server 20.04 LTS
Nginx 1.18.0
PHP 7.4.3
Nextcloud 20.0.8
OS: Alpine-linux
nginx version: nginx/1.18.0
PHP 7.4.15
Nextcloud version: 20.0.8

I am one of the initial reporters.

Forms seems to work, because i can access it by using a form shared link.
NC-domain/forms is not working > redirect to dashboard
301/302 Error by firefox

Ubuntu Server 20.04 LTS
Nginx 1.18.0
PHP 7.4.3
Nextcloud 20.0.8
NC behind revers proxy

Hello,
I have the same problem : Unable to go on the form page since last update · Issue #842 · nextcloud/forms · GitHub
I have tried to reboot the whole server but still the same problem :frowning:

In the past I’ve seen weird bugs with respect to routing (in other apps not related to Nextcloud) because the PHP $_SERVER environment variables are populated slightly differently for nginx setups compared to Apache. I’ve had no time to investigate yet, but this is the direction I would go first.

Edit: I have the same problem, but for me the whole setup is a fresh install, so I find it unlikely that it is a caching issue.

Hm, ok, so you did not update forms from v2.1?
Could one of you try to open a sharing-link of an owned form and append the ‘/edit’ part to the URL? Does that work?

Hello!
Here we are the same.
Forms work with shared links.
If we try to access the bar icon, it redirects to the first application you have configured.
This error appears when installing the latest update of the application.
I have completely rebooted the server with the same result.
Could it be related to the “OrderApps” app ???

Thanks!!!

Tested if it works

I can see the forms that I have created and the forms that have been shared with me.

Ok - So i meanwhile created a new instance with an nginx-server and played around for quite a while. The problem seems, that nginx appends a / to the route, which earlier always was a problem on apache, while nginx was less restrictive. Now we somehow turned that around, using a case where apache was less restrictive, but nginx not. Don’t ask me about details. :laughing:
I hope to have found a solution, that works now on both.
Sorry for the hazzle. :disappointed:

1 Like

@jotoeri so will there be another patch soon?

I hope so, yes… Depends now a bit on the reviews. :wink:

4 Likes

So just fyi - v2.2.2 is released.

3 Likes

It works ! Thank you :slight_smile:

+1
It’s Work!