Forced update to Nextcloud 25.0.1 resulted in red errors "regarding your setup"

I recently installed Nextcloud on Fedora Server 37, since the version I was using the previous two years was destroyed by an Ubuntu upgrade. All was working perfectly until this morning and the screen went blue with no other options and said you have to do a Nextcloud 25.0.1. Again, I had a green check on Security & setup warnings before this “forced” update.

Now I have " * Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation/Rescan.

Reviewing the list, it appears the be all files and most likely because Selinux blocks even me from looking at that data without "sudo vim/nano/ls + what I’m looking for. Obviously your documentation is not setup for Fedora Server 37.

sudo -u apache php --define apc.enable_cli=1 /usr/share/nextcloud/occ integrity:check-core

Produces the same list your error message discusses so that’s a waste of time

sudo -u apache php --define apc.enable_cli=1 /usr/share/nextcloud/occ integrity:check-app $appid

This just produces an error asking for an app ??? which app/ Seems pretty vague to me.

So I ran: sudo -u apache php --define apc.enable_cli=1 /usr/share/nextcloud/occ maintenance:repair

and it says everything is fine. Is everything fine? if so then your error message is bogus and needs to be fixed and please give us an explanation of what the update is doing before forcing us into an update. In short, give us the option.

By the way, I spent days working out the bugs of installing Nextcloud on Fedora 37 server. I finally got the green check. Now, a forced update makes me have doubts about reliability. Over four years ago, ya’ll advised me to remove Nextcloud from my MAC server that had been working pretty much flawlessly for many years ~2014-2018 or 19. The only buggy problem I had was Caldav and I solved that. So I went to Ubuntu that lasted a couple of years until an upgrade scattered it to the four winds. So I tried it on the latest Ubuntu and it didn’t seem as fast as Fedora, so I went to Fedora. I never had file integrity issues on the MAC as you described that I could have, so what am I missing here? It has been one headache after another on Linux. If this keeps up I’m knocking the dust off my old MAC-mini and loading it up.

SELinux and other protection mechanism might block some things that can result in errors or warnings. However for SELinux there is a page in the documentation:

Well it’s helpful for people who want to run such tests from other scripts or do updates via command line or when the server is in maintenance ode, so it’s not a waste of time, just another way to access this information.

Like for the core, you can just check the code of any of the apps as well. If you don’t specify the name of the app, it doesn’t know what to do.

That doesn’t repair the integrity errors of the code. The integrity test is just a warning that the code is different of that code that is usually shipped, but that might be on purpose if you modified the code.

if you follow a tutorial or something similar, it’s a good thing to share the information to their creator that they can fix the problems.

The problem was with PHP on mac platforms, that there was a risk loose data and there was not way to work around these issues. There were similar things on windows platforms.

It’s probably linked to SELinux what you don’t have on Mac platforms.

I had bad experience with major Ubuntu upgrades as well. I swichted for most server stuff back to debian, that seemed to be a bit more reliable regarding upgrades. However, I’m careful as well and take enough time so worst case I can install everything up from a fresh setup. Using virtual servers (LXC, proxmox) simplifies the task a bit to snapshot servers and reverse to previous versions.
I tried FreeBSD as well, there is just one version (unlike the many Linux distributions), a good documentation, … but less people are using it and some things are slightly different from Linux.
So the problem is to find a system that suits you the most and then check how to deal with the problems.

Thanks, I did work my way through the Selinux pages , but after I sent this note of frustration. The following two lines fixed the logging problem, not mentioned:

sudo semanage fcontext -a -t httpd_sys_rw_content_t ‘/var/log/nextcloud/nextcloud.log’

sudo restorecon -v ‘/var/log/nextcloud/nextcloud.log’

When I get time, I probably going to have to figure out file by file to clear the integrity check error.