For **** sake....when is nextcloud going to get updates right? <RANT>

Well here I am again. Ran the latest update and poof …it messed up and now I am left with “Update in process.” Message.

I am left (I think) in maintenance mode: on and trying to figure out how to turn it off.

All of the searches give me is “sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off” which doesn’t work.

Sit rep:
Nextcloud upgrade to latest version 18.
Running latest Unraid 6.8.2
Hardware: Dell R710
Self hosted.

The log files show that the update is done (I think).

I have run into this every time I upgrade to the next version. I can’t remember how to fix this from the last time. Been at it all day - the insanity is that I knew this would happen…:rage:

I am tired and giving up for the day … makes me wanna move to a less complicated solution.

If you have any suggestions and they work I promise I will document it for the next time - oh and there will be a next time I am sure.

I feel better now …going to bed. :smirk:

Cheers

Unfortunately this comes with the territory with these types of systems. Lots of variables from one system to the other, this is why many projects have switched to things like docker to reduce the variability between systems. Hope you had a good vent either way

Now for some potentially helpful notes:

If updates halted mid update you should probably attempt to re-run them via the terminal

sudo -u www-data php /var/www/nextcloud/occ upgrade

or

sudo -u www-data php /var/www/nextcloud/updater/updater.phar

If you just need to disable the maintenance mode you can manually edit the config.php and change the line 'maintenance' => true, to 'maintenance' => false,

As you are your own systems administrator you make sure to do your own backup prior to any update.

NOTE: The updater makes a backup as well, you will find that in the data folder data/updater-ocry####. I’ve never used this for a restore personally.

EDIT: I should note I never use the web updater and instead run this in terminal as I tend to encounter time-out issues. This has to do with my php setup and I have never bothered to fix it

4 Likes

Well I tried the command line and got this as a response:
Could not open input file: /var/www/nextcloud/updater/updater.phar

Same for occ upgrade.

Sounds like a permissions issue?

The system says it is owned by “nobody” - that sounds like a problem.

I even tried the updating of the config.php

Am I using the wrong config file?

This is what my nextcloud directory looks like:

The blocked out is my user id.

There are some strange directories in there.

And these are all the config.php within the directory that is most current…

All owned by “nobody”.

Which one is it? I am totally lost. :unamused:

How is your NC installed? What OS do you use?

Normally, Nextcloud files should be owned by the webserver user. This often www-data on Linux, but can be anything.

It is running on latest Unraid. 6.8.2.

It functions no problem. Just can’t get to OCC or anything else to complete the install (I think it is done) just need to get out of maintenance mode I think.

I did use updater (stoopid me) and I got the usual timeouts.

Cheers

Are you pathes correct?

Your images show different pathes like ‘mnt/user/nextcloud’

Please verify them.

Have you checked Unraid community regarding user of webserver and other things like mentioned pathes?

For **** sake….when is nextcloud going to get updates right?

Just refuse to use any free software/providers that do not offer concierge level customer service.
That will teach them pronto… /s

@anon71540698 Just don’t write topics that don’t contain concierge-level content, then you’ll quickly learn to be taken seriously … SCNR

1 Like

Oh forgot to mention that it is the linuxserver/nextcloud docker that I installed.

Thanks Henry …that was really helpful…

Well, as usual it didn’t take long for the knives to come out.
Really disappointed - again.
I really do ask dumb questions (not knowing their dumb but wait for users like Henry to point that out).
Just starting out with Nextcloud and have had some limited success.
I really didn’t post here to be abused or berated by the Nextcloud gods (legends in their own minds).

Thanks to users dugite-code. Gatak and I think rakeniven (although not really sure) for an honest attempt to assist me. You folks do make it welcoming and try to help.

I will going elsewhere for answers - oh and Henry I have a movie I want you to watch - you will love it - its all about you … https://www.imdb.com/title/tt10011682.

I will post back the solution so that it might help others. Which is what this is supposed to be all about.

Bye

Ok, that is an important information.
How do you connect to your docker container?
Do you use ssh to get to a prompt to enter commands?

I am asking this because your screenshots show windows icons, or?

The pictures look like WinSCP, so Windows is probably a good guess.

@toolmanz Don’t get demotivated by people like him. There’ll be always someone who is putting a pinch of sarcasm somewhere.

Back to topic:

If it’s a docker container, you need to either access the docker container via SSH first and use the occ command (i.e docker exec -it <container name> /bin/bash) or you can execute the occ command from outside the docker by sending the command to that docker container (i.e docker exec <container name> '/var/www/nextcloud/updater/updater.phar')

1 Like

The title of your post IS abuse!
You post another thread starting with FFS, and I’ll spell out the answer without any sarcasm…

And to return the favour, here is a book for you

2 Likes

No, the problem is that you have no idea how Docker works, but you blame Nextcloud for it. :wink: Docker works inside the container with its own user. A user that is not recognized by your host system and therefore prints as nobody. This is quite normal under certain circumstances and also the reason why you should work inside the docker container.

I think the tips from @CFelix are a good start.

1 Like

:roll_eyes:
For fuck’s sake, when are posters going to get projection right? RANT

Hello,

the author of this thread totally changed the title and content of first posting of this thread.

I reverted it to keep discussion complete and will close the topic in a few seconds.

If you need help, please open another topic and all posters should stay objective.

2 Likes