Folder Sync Connections lost after Win10 Nextcloud-Client upgrade to 3.0.1

I did the upgrade to 3.0.1
When I started “Settings” to view the status of each my Folder Sync Connections, only one (out of 13) was present.

Just to be sure, in case a system reboot might help, I rebooted. Now two showed up.

I stopped Nextcloud-Client and restarted it. Now three Folders showed up.
Obviously, I repeated and got all 13 back.



Warning: the subfolder options are lost.
That means problems for Sync onto a limited storage machine, e.g. a laptop.
So need to deselect subfolders that are not needed.

Can you try changing a file in a missing folder? I heard that is sufficient to make the folder to reappear in the client.
I haven’t tested this myself but someone else reported that.

@AlfredSK Thanks for the suggestion.
I am almost certain that this will not make any difference.
Here’s why:
Two of my sync folders are BobW/AppData/Roaming/Thunderbird and
BobW/AppData/Roaming/Mozilla (containing Firefox). These two folders (email and browser, respectively) get constantly updated. I did not see missing folders appear in the settings, as I did when I repeatedly exited Nextcloud-Client.

I have identical behaviour on a Win10 system that was working perfectly until this upgrade.
Is there an answer for the problem yet, or do we need to restart multiple times to be sure everything is working?

I can confirm this. Not only the folder sync settings are lost partially, folders bigger than X get stopped from being synced at all. After enabling them again, I have to download 2.5 TB again from my cloud to my local computer. This is annoying, since the files are stil there.

Is there a bug report area somewhere? This is a no go for “stable”, in my opinion.

Edit: restarting the client solved it somehow. So
1.) renable all the stopped folder syncs
2.) shutdown the sync app
3.) start the sync app
4.) check for unticked folders, tick them
5.) go to 2 until the situation was solved completely

This saved me from syncing and downloading all the files again

Good shout @Mort_Q
There’s a bug already open on this, so I added more details there.

1 Like

It looks as though developers are looking into this.
Several different bug reports all collapsed down to this one: