Folder linked to "/" causes excessive memory usage

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 27.1.4
Operating system and version (eg, Ubuntu 20.04): Ubuntu 23.10
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.4): PHP 8.2.12

The issue you are facing:
When a folder is linked to “/” the desktop client enters an infinate loop, and takes up all avaliable memory

Is this the first time you’ve seen this error? (Y/N):
Yes

Steps to replicate it:

  1. Have a folder linked to “/”.
  2. Let the desktop perform a normal sync.

The output of your Nextcloud log in Admin > Logging:

No logging avaliable

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '**',
  'passwordsalt' => '**',
  'secret' => '**',
  'trusted_domains' => 
  array (
    0 => '**',
  ),
  'datadirectory' => '/cloud/data/',
  'tempdirectory' => '/cloud/tmp/',
  'dbtype' => 'mysql',
  'version' => '27.1.4.1',
  'overwrite.cli.url' => '**',
  'htaccess.RewriteBase' => '/',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '**',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '**',
  'mail_smtphost' => '**',
  'mail_smtpport' => '25',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '**',
  'mail_smtppassword' => '**',
  'default_phone_region' => '**',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'maintenance' => false,
  'redis' => 
  array (
    'host' => '/tmp/redis.sock',
    'port' => 0,
  ),
  'files_no_background_scan' => false,
  'loglevel' => 2,
  'chunkSize' => '512MB',
  'app_install_overwrite' => 
  array (
    0 => 'hsts',
  ),
  'bulkupload.enabled' => false,
);

The output of your Apache/nginx/system log in /var/log/____:

No logging avaliable

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

No logging avaliable.

BTW! I was not sure if this was a bug - its more meant for troubleshooting scenarios

Do you mean / on your workstation or / of your Nextcloud Server account?

There are two sides to the sync setup:

  1. The remote, which is either set to grab everything from the server… Or is set to selectively choose various folders.

  2. The local folder, which is the destination/source folder on your local workstation.

Also, what version of the client are we talking about?

The linked folder is on the client / desktop.

I was on desktop version 3.9.0 (via apt) on a Ubuntu 23.10.
(I know it’s not the newest, but I could not find an issue created about it)
Do you want me to test the latest?

I extracted the heap through gdb, and found the folder there.

My lead:

/.steam/root/steamapps/common/Proton 7.0/dist/share/default_pfx/dosdevices/z:/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/proc/11344/root/

The root-folder in 11344 is a link to “/”:

lrwxrwxrwx 1 phnoggie phnoggie 0 dec  2 21:30 root -> /

Btw my solution was to exclude “.steam/”

If you need any logs, I need some instructions, because the client just makes my computer freeze without crashing (no OOM-kill)