FIXED: Cannot write into config or apps directory

Nextcloud version:
Operating system and version: Synology
Apache or nginx version: Apache 2.2
PHP version: 5.6
Is this the first time you’ve seen this error?: Yes.
I don’t believe I changed something, but there might have been an update by Synology to it’s “Web station” package.

Can you reliably replicate it? (If so, please outline steps):
Open Nextcloud home in browser

The issue you are facing:
I don’t get a login window but the message Cannot write into “config” directory and Cannot write into “apps” directory
The Apache user/group is http/http. All files inside my web directory (including the nextcloud installation) are owned by http.http . config.php is rwxrwx—. PHP’s open_basedir includes my web directory. I have no idea.

The output of your Nextcloud log in Admin > Logging:
Can’t access the log via browser, but here’s data/nextcloud.log:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:
This is /var/log/httpd/apache22-error_log:

Fixed it myself. The extended permissions set by the synology web tool were not suitable for nextcloud. I did chmod 770 on the files, that did it. I will now have to change the directories to something more suitable.

mine does not work. i tried chmod 770, the error page still keep showing up occasionally. i think it is something to do with the docker. since docker run as root and always write root files.

EDIT: my bad. i was running 2 docker containers that ran the same server (backup), causing conflicts and weird things. took me 2 days to figure it out.