First time setting up NextCloud in Truenas Scale

I see this error The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running "occ db:add-missing-indices" those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster. Missing optional index "fs_storage_path_prefix" in table "filecache". Running occ db:add-missing-indices doesn’t do anything in shell. suggestions? I am using App Version:

Running Nextcloud 29.0.0.19

Chart Version:

2.0.5

Thanks a bunch

Is your database PostgreSQL or MariaDB/MySQL?

postgres:13.1

I solved that issue now on to the next

Console has to be executed with the user that owns the data directory
Current user id: 0
Owner id of the data directory: 33
Try adding 'sudo -u #33' to the beginning of the command (without the single quotes)
If running with 'docker exec' try adding the option '-u 33' to the docker command (without the single quotes)
# occ config:system:set maintenance_window_start --type=integer --value=1
su: unrecognized option '--type=integer'
Try 'su --help' for more information.
# 

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.