First maintenance release for Hub 5

Originally published at: First maintenance release for Hub 5 - Nextcloud

Nextcloud Hub 5 has its first minor update out, plus updates to Hub 4 and 3.

As always, minor releases include stability and security improvements that are designed to be a safe and quick upgrade.

You can find the full changelog of fixes and improvements for these releases on our website.

Note: There will be no more releases of Nextcloud Hub 2 (24.x.x and older). Upgrade to Nextcloud Enterprise to continue to get security and stability updates or move to Nextcloud Hub 3 or Hub 4. Don’t forget that running web-facing software without regular updates is risky. Please stay up to date with Nextcloud releases of both the server and its apps, for the safety of your data! Customers can always count on our upgrade support if needed.

Note²: PHP 7.x is no longer officially supported by the PHP community. Nextcloud has supported PHP 8.0 and newer versions for some time now, and we strongly recommend you move to a newer version of PHP. Version 8.0 is already out of active support (!) and has only a few months of security updates left. Nextcloud Hub 3 (25.0.x) deprecates PHP 7.4 but still works with it. Still we recommend you use PHP 8.1 or newer. Hub 4 and newer support PHP 8.2.

Ready to move to Nextcloud Hub 5?

Nextcloud Hub 5 was released last month and we highly recommend that you upgrade to benefit from the latest features. Check out the release announcement here.

Stay safe: keep your server up-to-date!

Minor Nextcloud releases are security and functionality bug fixes, not rewrites of major systems that risk user data! We also do extensive testing, both in our code base and by upgrading a series of real-world systems to the test versions. This ensures that upgrades to minor releases are generally painless and reliable. As the updates not only fix feature issues but also security problems, it is a bad idea to not upgrade!

If you are maintaining a mission-critical Nextcloud system for your enterprise, it is highly recommended that you get yourself some insurance (and job security… who gets blamed if the file handling system isn’t working as expected?). A hotline to the core Nextcloud developers is the best guarantee for reliable service for your users, and the job safety of you as a system administrator.

Hub 5 is Nextcloud 27! Here is a table with supported php version vs. NC versions:

NC version php 7.3 php 7.4 php 8.0 php 8.1 php 8.2 php 8.3
22 :white_check_mark: :white_check_mark: :white_check_mark:
23 :white_check_mark: :white_check_mark: :white_check_mark:
24 :white_check_mark: :white_check_mark: :white_check_mark:
25 :white_check_mark: :white_check_mark: :white_check_mark:
26 :white_check_mark: :white_check_mark: :white_check_mark:
27 :white_check_mark: :white_check_mark: :white_check_mark:
28 :white_check_mark: :white_check_mark: :white_check_mark: :white_check_mark:
29 :white_check_mark: :white_check_mark: :white_check_mark:

For Debian users the switch goes directly from php 7.4 to 8.2:
Bullseye 11: 7.4
Bookworm 12: 8.2

If you are on Bullseye 11, you can either use a 3rd-party package to have at least php8.0, then upgrade to NC 26 or later and then upgrade the system to Bookworm.

You can try on Bullseye, to get up to NC 25. Then upgrade to Bookworm. NC25 itself does not support php 8.2, so you can’t just run the updater. But you can do a manual upgrade, where you just keep the data/ and config/ folder, you remove the code from NC25, you download and copy the code for NC 26 (Nextcloud server changelog), and then run php occ upgrade. The code of NC 26 is compatible with php8.2.
The only issue: if there is a problem, you have change your OS version, php version and the NC version, you need to figure out where the problem is!

2 Likes

That statement is correct, but very misleading. PHP7.x is still
supported as part of the Debian project.

It depends what you call support. In this context, it was the version that is supported by the php developers. Debian backports fixes from newer php version back to 7.4. If someone finds a bug that only works on versions older than php 8.0, the php developers won’t create a fix for that. Perhaps the information is passed to the Debian maintainers, so they can do it. If it required important modifications, would/could they do it?

I would consider it as a grace period to buy some time until I can upgrade to a more recent Debian version that brings “full” support (php developers + debian maintainers).