First boot, rainbow screen

Got my box today.

Installed RPi2 V1.2 on it. Followed instructions and inserted the SD card provided.
Nothing happens, only rainbow square on screen over hdmi output.

After quite some time in forums couldnt find a fix. Went to IRC #Nextcloud
They suggested flashing again SD card.
Flashed latest version following official instrucions.

Rainbow of death again.
Kinda desperate, can someone point me out in the right direction?
Thank you

I had the same problem with a Raspi - the system was not able to find the boot files when the rainbow screen appeared. How did you flash the SD card?

I followed the official instructions at nextcloud box wiki

I use linux so I did exactly what it says there. No luck.

If your Rpi is stuck in the rainbow screen it means the SD is not created properly and there is nothing it can boot from. Make sure you use the correct image (for Rpi 2 or Rpi 3).

Also what you can do is first get the original Raspbian image to confirm the Rpi is working normally.

Yes I did that. I flashed a Raspbian image and it worked perfectly, so I
know my SD and RPi work well. But the SD card provided with the already
flashed image and the official image (both RPi2 and RPi3) that I have
flashed on the same SD card failed to boot.
There is something with those images that doesn’t work well with my RPi and
I dont know what it is.


I have the exact same issue: my Raspberry Pi is Model B v1.2 , and I know there might be issues with its CPU, but how was I to know this exact Pi model wouldn’t work ?
On the Pi the red LED is turned on and the green one flashes 4 times slowly then 4 quickly.

So I tried flashing the Pi 2 image and the Pi 2 and Pi3 but nothing works. What is there to do now ?