First Backup always fails

Hi y’all,
I have searched everywhere but couldn’t find my problem anywhere neither here nor anywhere else at places like stackoverflow.
My situation is the following:
I am running nextcloud aio v6.2.1 on a docker for mac.
It runs flawlessly and reliably!

The only problem I face is that I can’t create a first backup.
After it ran (as it seems fully) the log always shows this at the end:

Backup failed!
You might want to check the backup integrity via the AIO interface.
Deleting borg.config file so that you can choose a different location for the backup.

(The borg.config file has not been deleted)

Early on in the log it says that files have been changed “while we backed it up”.
first these:

ud_aio_volumes/nextcloud_aio_nextcloud_data/audit.log: file changed while we backed it up
76.94 MB O 10.08 MB C 8.27 MB D 1997 N nextcloud_aio_vol...d_data/fts-index.done
ud_aio_volumes/nextcloud_aio_nextcloud_data/fts-index.done: file changed while we backed it up
/nextcloud_aio_volumes/nextcloud_aio_nextcloud_data/index.html: file changed while we backed it up
/nextcloud_aio_volumes/nextcloud_aio_nextcloud_data/skip.update: file changed while we backed it up

Then what seems to be rather unimportant: 3 user avatar files.

It seems like the backup ran, the size of the created data seems reasonable, the borg.config was not deleted, but the AIO control panel always says this:

You may change the backup path again since the initial backup was not successful. After submitting the new value, you need to click on Create Backup for testing the new value.

I have tried different paths on different volumes and lastly even tried with full permissions on the directory.
As of now it is an sshfs volume mounted into a local path.

Does anybody have a clue what to check next?