Files with u0306 character in the name can't be synced and are deleted from synchronized folder

Support intro

Nextcloud version: 27.1.0
Operating system and version: Ubuntu Server 22.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version: 8.1
Nexcloud windows client: 3.10.0
Windows 11 22H2 build 22621.2283

Hi everyone! I’ve recently started the journey of self-hosting and migrated my cloud file storage to Nextcloud. Liking it so far, but I’m facing a strange issue:
Nextcloud Windows client can’t sync and deletes files that have some non-standard Cyrillic characters in their names, specifically ones with unicode: \u0306, which is a part of weird way to write Russian “й” letter.
After adding such a file to synchronized folder, in the main dialog log window you get 2 messages:
You created <>
Synced <> with red cross status - deleted.

I can upload the same file via web-interface with no issues, but as far as I can tell while doing so it converts the letter “й” in the name of the file which consists of 2 unicode characters \u0438\u0306 to a single unicode character \u0439.

Is this the first time you’ve seen this error?: No

Steps to replicate it:

  1. Put any file with a U+0306 into a synchronized folder on windows PC

The admin log doesn’t contain any messages of such files, I also wasn’t able to find any mentions in other logs, but I’m not sure I’m looking in the right places.
Would be really great if you could point me in the right direction.

P.S. I’ve checked my system locale settings in windows - they are correct, I also tried “Beta: Use Unicode UTF-8 for worldwide language support” option, like it was suggested as a solution in other issues, no luck though.