Files:scan error [SOLVED]

Nextcloud version (eg, 20.0.5): 21.0.4
Operating system and version (eg, Ubuntu 20.04): 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.25
PHP version (eg, 7.4): 7.4

The issue you are facing:

When i run this command sudo -u www-data php occ files:scan i get the following error message

 There are no commands defined in the "files" namespace.

BTW I was in maintenance mode when i ran the command

can anyone please tell me whats wrong with my setup?

Ok, I’m running a docker based setup and when I try to make it run as you did I get the following output

docker exec --user www-data nextcloud-app php occ files:scan
Please specify the user id to scan, --all to scan for all users or --path=…

Could it be there is some missing stuff in your cmd or smt like that?

i even tried whats given in the help page, i get the same error… no logs are getting generated though

sudo -u www-data php occ files:scan --help

Add --all to the end of your occ command or define a user.

sudo -u www-data php occ files:scan --all

that worked but wondering why --help doesnt.

–help doesn’t appear to be an option. See midway down on page link:


this command doesnt work when maintenance mode is set “on”

1 Like

Good to know. Glad you got it sorted.