Files not visible in the web frontend (Uncaught TypeError: Cannot read properties of undefined (reading 'prototype'))

Nextcloud version (eg, 20.0.5): 24.0.5.1
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11. 5.15.83-1-pve (x86_64) within Proxmox 7.3-4
Apache or nginx version (eg, Apache 2.4.25): not sure
PHP version (eg, 7.4): 8.1.10

The issue you are facing:
The web frontend is suddenly not displaying any files anymore, just a white empty screen:

I did run file-scan, rebooted, cleared temporary files, tried different browsers on different devices, everywhere the same result.
Files are there and accessible (up- and download) from the Nextcloud app and via Samba and WebDav. Also the dashboard in the frontend shows a few files that are accessible, the photos section shows all fotos, and when changing the user avatar picture the opened window also shows everyhing, so it is just a frontend issue in the browser.

When opening the files section, Chrome developer tools show multiple errors:

That seems to be the files section, the shared section and the trash bin section, which all remain white pages

Following that filelist.js, it shows

I have found a few other posts here and in other forums about a white files section, but either with other errors or without solution.

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. Login to Nextcloud
  2. Go to the files section.

The output of your Nextcloud log in Admin > Logging:

Nothing

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    7 => 'nextcloudpi',
    5 => 'nextcloudpi.local',
    8 => 'nextcloudpi.lan',
    3 => 'nextcloudpi',
    11 => '2003:xxx',
    1 => 'xxx',
    14 => 'nextcloudpi.local',
    20 => 'xxx,
    21 => 'xxx',
    22 => xxx',
  ),
  'datadirectory' => '/mnt/myCloudDrive/ncdata',
  'dbtype' => 'mysql',
  'version' => '24.0.5.1',
  'overwrite.cli.url' => 'https://nextcloudpi/',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'ncadmin',
  'dbpassword' => 'xxx',
  'installed' => true,
  'instanceid' => 'ocs58qui8ele',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => 'xxx',
  ),
  'tempdirectory' => '/mnt/myCloudDrive/ncdata/tmp',
  'mail_smtpmode' => 'sendmail',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'admin',
  'mail_domain' => 'ownyourbits.com',
  'preview_max_x' => '2048',
  'preview_max_y' => '2048',
  'jpeg_quality' => '60',
  'overwriteprotocol' => 'https',
  'trusted_proxies' => 
  array (
    11 => '127.0.0.1',
    12 => '::1',
    13 => 'nextcloudpi',
    14 => '',
  ),
  'maintenance' => false,
);

The output of your Apache/nginx/system log in /var/log/____:

Do not see anything for the relevant time in all the different logs in apache2 folder

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Nothing

Hi, can you upgrade to 24.0.9 and check if that helps?

I had previously done an upgrade to 24.0.8.something, which then led to a disappeared app store (only installed apps displayed, all app store pages white without any content). All forum threads I found about that in the end reinstalled or loaded a backup as a solution.
So I had also loaded my 24.0.5. backup, where the apps store still worked. I am not sure if the issue with the files section only started with that or was present already before, as I do not use the web frontend regularly for files management. However at least the apps section is again fine with that.

I can copy my container and try another upgrade on that. But is there an indication that something in that direction got fixed lately, or is it just “have you tried the latest version”? :wink:

After reverting to an older backup and upgrading again, the issue was gone. So for the moment no open issue anymore on my side, but such errors without a clear root cause and fix are not so convincing…