Files and storages are no longer displayed in system settings


Please help me with nC problem.

we had nextcloud 20.09 up and running on old server and we wanted to migrate it to a new more powerful one.
so, on old server, i upgraded instance to nc21, migrated to postgresql from mariadb, transfered all files to a new server, dumped pgsql database.
on a new server, created dabase, imported a dump, but before that changed local:: to match new data directory, changed path in config.php, changed owner to www-data to all directories for nextcloud installation and data.
started a new server.
everything works great, but when i am going in system settings, i am getting files: 0, storages: 0
tried files:scan --all and it ran very quickly, in about 5 minutes, however on an old server it was running vqey slowly as we have 235 gb occupied space with files.

do you have any ideas why nc could show 0 files and storages?


just for your reference official server migration guide

from your description it sounds like you completed all the steps you need… maybe you mistyped the path somewhere? I would suggest you create some files from your new NC web interface and review if the files are stored in the expected location.

I’m little confused about this statement:

did you try to change storage variant somehow? I would recommend not to add additional complexity and migrate everything exactly the same (like local storage to local storage, keep external storage as is) and adopt the system after the hardware change is successful.


Yes, new storage works, and in files app all files are visible. new files can also be added and they are also visible in files app.

the only thing is that in system settings, nextcloud displays:
files: 0
storages: 0

i moved nextcloud data directory out of webroot, because of that i changed local::/old/path to local::/new/path, and also i changed a path in config file.

maybe you find a hint i this posts:

Everything is OK and after the update from 20.0.9 to 20.0.10 this is the error.

Settings > System > Disk

You will get a notification once one of your disks is nearly full.

Files: 0

Storages: 0

Free Space: 367,5 GB

I think the problem is only with that notification. Only that part is broken, all the system is working properly and does not need any correction and any other problems are not related.

yes, it will be good to fix that problem, as it gives fault notification. everything else works correctly.

@Gozaltech @vascocb
Had the same problem and found a solution.

Use “occ serverinfo:update-storage-statistics” (Triggers an update of the counts related to storages used in serverinfo).

Hope this helps!


Thanks, that worked


Data is not automatically updated. It is always necessary to run the command to update the data.