File view blank after updating to 20.0.8

Nextcloud version : 20.0.8
Operating system and version : FreeBSD 12.2-RELEASE-p3 FreeBSD 12.2-RELEASE-p3 7851f4a452d(HEAD) TRUENAS amd64
Apache or nginx version : Apache/2.4.46 (FreeBSD) (fpm-fcgi)
PHP version : 7.4.15

The issue you are facing:
After updating to 20.0.8 (from 20.0.7, using updater.phar), no files are shown on the main files view. Menus show up on the left side, and I can reach the settings page, etc. If I create a new file or folder (using the New Folder option), nothing shows in the file view. It does show up on the server as “New folder”, with the correct date and time.

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. Ran su -m www -c ‘php /usr/local/www/nextcloud/updater/updater.phar’
  2. Allowed script to start update
  3. Allowed script to run “occ upgrade”
  4. Did not leave maintenance mode active

Script reported success everywhere, but I did see the errors about (see next section below)

The output of your Nextcloud log in Admin > Logging:

PHP Startup: Unable to load dynamic library '' (tried: /usr/local/lib/php/20190902/ (/usr/local/lib/samba4/ Undefined symbol "memalign@FBSD_1.6"), /usr/local/lib/php/20190902/ (Cannot open "/usr/local/lib/php/20190902/")) at Unknown#0

Error: Undefined index: readonly at /usr/local/www/nextcloud/apps/support/lib/Sections/ServerSection.php#268

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'redacted',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' => 
  array (
    0 => 'redacted',
    1 => 'redacted',
  'datadirectory' => '/mnt/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://redacted',
  'overwritehost' => 'redacted',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/tmp/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud_admin',
  'dbpassword' => 'redacted',
  'installed' => true,
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'enable_previews' => true,
  'enabledPreviewProviders' => 
  array (
    0 => 'OC\\Preview\\PNG',
    1 => 'OC\\Preview\\JPEG',
    2 => 'OC\\Preview\\GIF',
    3 => 'OC\\Preview\\BMP',
    4 => 'OC\\Preview\\XBitmapPNG',
    5 => 'OC\\Preview\\TXT',
    6 => 'OC\\Preview\\MP3',
    7 => 'OC\\Preview\\MarkDown',
    8 => 'OC\\Preview\\Photoshop',
    9 => 'OC\\Preview\\PDF',
    10 => 'OC\\Preview\\TIFF',
    11 => 'OC\\Preview\\SVG',
    12 => 'OC\\Preview\\Movie',
    13 => 'OC\\Preview\\MSOffice2007',
    14 => 'OC\\Preview\\Font',
  'trusted_proxies' => 
  array (
    0 => 'redacted',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => 'redacted',
  'mail_smtpport' => '587',
  'mail_from_address' => 'redacted',
  'mail_domain' => 'redacted',
  'mail_smtpname' => 'redacted',
  'mail_smtppassword' => 'redacted',
  'maintenance' => false,
  'preview_max_x' => '1024',
  'preview_max_y' => '1024',
  'jpeg_quality' => '60',
  'theme' => '',
  'loglevel' => 0,

Pastebin of browser Javascript console from loading the “Files” tab

Have you seen this bug report:

Thanks for the quick reply!

I did find that bug report and was able to update my nextcloud jail from FreeBSD 12.1 to 12.2, and then run pkg upgrade to update all the packages installed within the jail. That fixed the issues with smbclient, but nextcloud itself still behaves the same.

Judging by the large number of errors reported in the Javascript console, I suspect that the underlying FreeBSD issue may have caused the update to somehow break, but the updater didn’t catch it and reported everything’s OK. I found and reviewed updater.log, there were no error messages there. Is there a way to force the updater to “re-install”? Or to revert back to 20.0.7 (sorry, my original report stated I had upgraded from 20.0.4) without having to reinstall?

Hello Jim,

this happened to me also after updating. Since i did not mind reinstalling tNC completely new, i did not. It was not easier than trying to find out how to fix it. Before doing a fresh reinstall, i backup my data folder and some config to the external drive and after that I took my NC offline first and moved the data dolfer outside my installation and deleted NC competely. After reinstalling NC and everything is working again, i just created the main folders and users and moved the data back to its corresponding places and went to OCC Web and issue “files:scan --all” then I am back to business. you can do this if you cannot find any solution.

Good luck!

Thanks Cyrus.

On my installation, the data directory is outside the standard Nextcloud tree, so I downloaded the 20.0.8 tar file, went to maintenance mode, backed up my database (mysql dump), renamed the old tree and un-tarred the freshly downloaded archive. I copied over the config.php, came out of maintenance mode and tried an occ upgrade. As expected, I got “no update required”. Same errors remained, though - my file view is blank.

Since I did the backup, I figured it would be safe to switch to the beta channel and update to NC 21. This time I used the web updater instead of updater.phar, and it seems to work fine now (file views are ok).

Just as an additional data point, when I was still on 20.0.8 and the file view was empty, I could access NC via DAV and the desktop clients without issue, only the web client wasn’t working.

A couple of apps I had set up aren’t working on 21 (also nervous to be on a beta), so if anyone has any ideas on what went wrong I’m willing to try reverting back to 20.0.8.

I had the same issue with 20.0.8. so I updated to version 21. I am not a NC expert but from what I know you cannot downgrade.

NC21 was already released, it is not beta anymore. Some apps and their developers need a bit more time to adjust to the new versions. You can check on their repositories, if they started working on it and the status.

You can’t downgrade, however if you have a backup and restore from before the backup, that’s no problem. For that reason, it’s good to make a full backup before upgrading.