File versions not working with duplicate name of versions

file versions is not working, activities appeared but the Versions is blank and i have noticed duplicate name of Versions


I’ve noticed it depends on how the file is worked. For example Keepass creates a temporary file, deletes the old database and then saves a new database. This breaks the Versioning.

Check your deleted files list


can you find your files via terminal? file versioning directory is: nextcloud/data/rsumook/files_versions

there is a files_versions directory

in my config file i point the data directory to this path

‘datadirectory’ => ‘/home/data’,

Well it looks like there is a version of your file exists.

If it was a normal file I would say give a occ file:scan a shot but I don’t know if that works with the files_versions directory.

Just a clarification:
You’ve said your data directory is out of the nextcloud folder but is the screenshot you posted from the nexcloud/data/*rsumook*files_versions folder or your /home/data/*rsumook*/files_versions director?


[root@owncloud files_versions]# pwd
[root@owncloud files_versions]#

the location of my NC
[root@owncloud nextcloud]# pwd
[root@owncloud nextcloud]#

but for the data
[root@owncloud files_versions]# pwd
[root@owncloud files_versions]#

is this correct command which one is correct

sudo -u apache php occ files:scan -p /home/data/rsumook -v
sudo -u apache php occ files:scan --all

Both will scan you user folder, but again I don’t know if it will help. Shouldn’t hurt though.

no luck still no versions

Experienced similar symptoms on v13. Turned out to be issue with enabled Snapshots App. Disabling app removed double “versions” links and versions of files appeared.

I shall still investigate Snapshots app issue, as might be wrongly configured. But disabling this app, solves file versions at least for me.

1 Like

Ok thanks for your tip i will try this and ill update you soon

Thanks j2b disabling snapshots it works like charm :slight_smile: