File stuck - can't move or delete it

Hi. I’m a relatively new user of Nextcloud. I seem to be getting a lot of random issues with files not syncing properly, and things not behaving as I would expect. At first I blamed my own lack of experience. But some issues seem more like bugs. Here’s a specific one that happened today.

I have a file in a Nextcloud folder that is permanently stuck. I am using the standard Nextcloud web interface and clicking the three dots alongside the file name. I can’t delete it. I can’t move it. I can’t rename it. In each case I get a popup at the top right of the screen with these messages.

Error deleting file "REB IMG_20200408_182954807.jpg".
Could not move "REB IMG_20200408_182954807.jpg"
Could not rename "REB IMG_20200408_182954807.jpg"

How the file got there is a long story and I won’t bore you with the details. In summary another user shared a file with me and I made a copy of it. It was in fact the same as a file I already had, but with a different name. I tried to copy it into the same folder as the other file and I think Nextcloud has somehow confused the two files.

It’s not worth going through the sequence of what went wrong step by step. But I do need to find out how to fix the problem now.

The file is visible in the web interface. But, as noted above, I can’t do anything with it. In the details pane it says -

You deleted REB IMG_20200408_182954807.jpg 13 minutes ago
You created REB IMG_20200408_182954807.jpg 2 hours ago

So Nextcloud thinks it has been deleted, but it’s still there. The admin log contains nothing that is relevant.

I also tried deleting the file in the desktop client and re-syncing. The file has now gone from the desktop client, but is still shown in the web interface. And the file is still on the server because I can see it with FTP. I suppose I could just delete it with FTP, but I don’t want to do anything that will mess up the database integrity.

Can anyone suggest how to sort this out?

I’m using Nextcloud 17.0.2

2 Likes

Hi

I’m having exactly the same problem with Nextcloud 18, even after upgrading to 19 and 20.
I’ve tried everything on HD and on interface.

Regards

Had the same issue as what you described here:

The information from these links may help: File is locked - how to unlock
File is locked - how to unlock
File is locked - how to unlock
File is locked - how to unlock
File is locked - how to unlock

Here is some background information of my installation: