File Permissions vs Folder

Shared Folder is set for create, edit, delete for group ‘Planning’

How to make a file read only in a folder with all permissions?

If I add the group ‘Planning’ to the file share and uncheck Edit it doesn’t work. Members of the group can still edit the file.

Appears that folder permissions override file permissions.

It doesn’t work that way. The permissions are handled based on the share used to access the file. In other words, it’s not that the folder’s permissions overwrite the file’s. They simply aren’t in effect.

If you share a folder, and then also share a file in it with its own link, the permission you have is based on which link is used.

If I’m not mistaken, the same concept applies to things shared directly with a user instead of with a link. Each individual “share” has a set of permissions attached to it.

You might be able to do something to suit your needs with the file access control app.

I tried to share a file in a folder (Epic Public) for group ‘Epic’ with all priv by selecting the same group only disabling all permissions. That didn’t work. Tried file access control, too general.

So will have to create a folder in the Public folder called ‘No Edit’ or ‘Read Only’ and put files restricted to read only in there.

Thanks for the suggestions.