FILE_MISSING -> Integrity check error shows 3rd Party entire folder missing. folder is present


Very new in this forum, hope I don’t make many mistaks.

First, I installed Nextcloud in a

Debian 11,
PHP 8.2

all works very good, server is working fine.
But, when I make integrty check I have

Some files have not passed the integrity check. [List of invalid files…] [Rescan…] For more details see the [documentation :arrow_upper_right:]

Checking the list of missing files, is the entire 3rdparty folder, which is in place, with the right permissions.

Also, in the config.php file, I have tried to remove the config for 3rdparty apps, it didn’t work, and is point it with the right location, even if I commented or remove the location of the folder the message is the same, and the files are exactly the same missing ones.

I migrated from Owncloud, to nextcloud 25, then upgraded all the way to nextcloud 28.

I’m lost in how to make the error dissapear.

Thanks in advance

The 3rdparty folder is an internally used folder. There is no reference to the ~/3rdparty folder within a conventional config.php file. Can you please post your actual configuration?

  • occ config:list system (or equivalent)

What installation method did you use? And I assume you already clicked “Rescan”, correct?

Can you also post at least a snippet of the scan results?

Thanks for your response.

The method I used was, manually upgrade.

i downloaded the upgrade version, extracted to the destination folder, and put back the config.php file.

manually resolving each error one by one, but with this one, I cannot make it work.

here is the config extracted with the command you suggested.

    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "https:\/\/",
        "dbtype": "mysql",
        "version": "",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "versions_retention_obligation": "30, auto",
        "appstoreenabled": true,
        "appstoreurl": "",
        "appsallowlist": [],
        "apps_paths": [
                "path": "\/home\/owncloud\/public_html\/apps",
                "url": "\/apps",
                "writable": true
                "path": "\/home\/owncloud\/public_html\/3rdparty",
                "url": "\/3rdparty",
                "writable": true
        "installed": true,
        "filelocking.enabled": true,
        "memcache.local": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_smtpauth": 1,
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "ssl",
        "mail_smtpport": "465",
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpauthtype": "LOGIN",
        "maintenance": false,
        "loglevel": 2,
        "default_phone_region": "BO",
        "allow_user_to_change_mail_address": "",
        "maintenance_windows_start": 1,
        "maintenance_window_start": 1,
        "enable_previews": true,
        "preview_concurrency_all": 8,
        "preview_concurrency_new": 4,
        "preview_max_x": 4096,
        "preview_max_y": 4096,
        "preview_max_filesize_image": 50,
        "preview_max_memory": 256,
        "preview_libreoffice_path": "\/usr\/bin\/libreoffice",
        "preview_ffmpeg_path": "\/usr\/bin\/ffmpeg",
        "preview_imaginary_url": "***REMOVED SENSITIVE VALUE***",
        "preview_imaginary_key": "secret",
        "enabledPreviewProviders": [

Also this is the scan results.

Technical information
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix

- core
		- 3rdparty/.github/dependabot.yml
		- 3rdparty/.github/workflows/block-merge-freeze.yml
		- 3rdparty/.github/workflows/composer-auto.yml
		- 3rdparty/.github/workflows/composer.yml
		- 3rdparty/.github/workflows/lint-php.yml
		- 3rdparty/.gitignore
		- 3rdparty/LICENSE INFO
		- 3rdparty/
		- 3rdparty/autoload.php
		- 3rdparty/aws/aws-crt-php/.clang-format
		- 3rdparty/aws/aws-crt-php/.clang-format-ignore
		- 3rdparty/aws/aws-crt-php/.gitmodules
		- 3rdparty/aws/aws-crt-php/
		- 3rdparty/aws/aws-crt-php/LICENSE
		- 3rdparty/aws/aws-crt-php/Makefile.frag
		- 3rdparty/aws/aws-crt-php/Makefile.frag.w32
		- 3rdparty/aws/aws-crt-php/NOTICE
		- 3rdparty/aws/aws-crt-php/builder.json
		- 3rdparty/aws/aws-crt-php/config.m4
		- 3rdparty/aws/aws-crt-php/config.w32
		- 3rdparty/aws/aws-crt-php/ext/.gitignore
		- 3rdparty/aws/aws-crt-php/ext/awscrt.c
		- 3rdparty/aws/aws-crt-php/ext/awscrt.stub.php
		- 3rdparty/aws/aws-crt-php/ext/awscrt_arginfo.h
		- 3rdparty/aws/aws-crt-php/ext/crc.c
		- 3rdparty/aws/aws-crt-php/ext/credentials.c
		- 3rdparty/aws/aws-crt-php/ext/crt.c
		- 3rdparty/aws/aws-crt-php/ext/event_loop.c
		- 3rdparty/aws/aws-crt-php/ext/http.c
		- 3rdparty/aws/aws-crt-php/ext/logging.c
		- 3rdparty/aws/aws-crt-php/ext/php_aws_crt.h
		- 3rdparty/aws/aws-crt-php/ext/php_util.c
		- 3rdparty/aws/aws-crt-php/ext/signing.c
		- 3rdparty/aws/aws-crt-php/ext/stream.c
		- 3rdparty/aws/aws-crt-php/

An so on, for alll the files contained in the 3rdparty folder.

Also I tried to remove the folder, and the system asks for it with general error, once I put it back, all works fine, but the same integrity check.

I made a rescan many times, restarting services, and the machine it self.

Hope you can help.
Thanks again

Oh, okay - now your error is making sense.

Looks like you configured some custom apps_paths.[1]

I see two problems here:

  • you have writable enabled for the shipped apps folder (/apps)
  • you have your local apps folder called 3rdparty which overlaps with a critical internal folder used by Nextcloud Server. I’d suggest something like custom_apps or local_apps or extra-apps if you want to have a folder for non-shipped apps

[1] Apps management — Nextcloud latest Administration Manual latest documentation

1 Like

Thanks a lot.

Removed that part of the config file. and after a reboot, and rescan, the error is gone.

Also, I uncompressed again the original downloaded file, and replaced all over again, of course keeping the config.php file.

Then, it worked.

Again, thanks a lot.

1 Like

Glad to hear it!

P.S. I’ve sent over an adjustment to the Apps Management chapter of the docs that adds a warning to help others avoid this[1].

[1] docs(admin): Warn to choose custom app values carefully by joshtrichards · Pull Request #11578 · nextcloud/documentation · GitHub

1 Like