File Encryption disabled but files are still encrypted


i noticed that for at least one user on my nextcloud installation some files are not readable anymore. not all, only some of them. While debugging i noticed that the files have an encryption header and the files seem to be encrypted.

File starts with:


When I run the occ encryption:decrypt-all, i get the following output.

root@debian-4gb-nbg1-dc3-1 /var/www/cloud/pages # sudo -u www-data php occ encryption:decrypt-all
Server side encryption not enabled. Nothing to do.
root@debian-4gb-nbg1-dc3-1 /var/www/cloud/pages #

Is there a way to troubleshoot this? I also noticed that for the corresponding files there is an existing keypair in the data folder structure data/user/files_encryption/keys/ …

Is there a way to encrypt the files by hand?
Is there a way to check if the keys in the data folder are valid for decryption of the real files?

Please help!

Best regards

Meanwhile i tried to enable encryption which gave me the following:

root@debian-4gb-nbg1-dc3-1 /var/www/cloud/pages # sudo -u www-data php occ encryption:enable
Encryption is already enabled

No encryption module is loaded
root@debian-4gb-nbg1-dc3-1 /var/www/cloud/pages #

Ignoring this, I tried to run a occ encryption:decrypt-all again. This time it said it successfully decrypted the files but i can see that the files are untouched…

Sorry to bump a dead thread, I was wondering if you’ve had any luck with this. It seems my server encryption randomly got enabled and this is the issue I’m facing as well.

Hi, did you solve this?