"File could not be uploaded" to external hard drive message

NextcloudPi version: ‘27.1.3’
running on a Raspberry Pi 4

The issue you are facing:
I attached an external SSD drive through USB to the rPi and have been trying to get it working properly so I can use it for cloud storage. I think it’s close. I labeled the external hard drive, enabled automount and when I open the Files app, the external appears with the label I gave it.
The issue is that any time I upload a file, after the progress bar fills I get the error “File could not be uploaded” without any further explanation.
I assumed it is an issue with sharing permissions, but the folder is labeled Shared in Files and when I click the three dots and go to Share Folder to see the options. It says Others with access and for Share link I’ve tried with it set to Can edit and File drop, but got the same error with both.

I assume there’s another spot where I need to allow uploads. I’ve only used the webUI and am still new to NextCloud overall, but I haven’t been able to locate it on my own.

I assume I’m overlooking something pretty simple. if anyone can tell me what I need to do I will be very grateful. and if you can explain it simply that would be even better

Thanks for any help you can provide.

I am not fully sure that this is your problem.

But many has reported that the external drive thing is buggy at the moment and a fix is on its way in 28.0.2 from what I read.

Check your logs for errors and Google them and you will see

Oh, that’s interesting. So maybe I need to hold tight until NCP is updated to 28.0.2?

Like I said, I’m learning NextCloud as I go along. How do I check my log for errors?
It’s probably simple, but I’m not sure where to look.


I kept looking around and may have found the Logs you were talking about.
There was an error but it was from days ago and I think it was corrected, because it didnt show up in later logs.

I did Control+F and searched for error, I’m not sure if there’s a better way I should have been doing it.

I did find out I’m using NextCloudPi v1.53.0
OS Debian GNU/Linux 11. 5.15.61-v8+ (aarch64)

Unless you or anyone else has other suggestions, I’ll have to wait for NextCloudPi to update to NextCloud 28.0.2 because I’m just spending a lot of time and not getting anywhere with this.