File access forbidden

Hello

I am running the collabora docker image on my RPi 3 with an nginx webserver. I followed this guide.

I can see the “Collabora Online” entry in left hand navigation pane in my WebUI admin section, which means to me, that the service is properly installed and the app has been activated.

In case the Collabora Online app has been activated in app store, I cannot access any file in file app any longer. I receive a blue screen of NC telling me the access is denied.

It doesn’t happen when Collabora Online app has been disabled in app store.


Not sure if this is important. In the “Collabora Online integration tutorial video” (found here at time 6:30) I saw an “Office” icon in the “app selector”. I am missing that. Is this related to the above described issue?

Is there a solution for this? What information did I miss to provide to get you able assisting me to get this solved?

Kind regards
//neph

Hi!
I have the same problem. Also a german version of NC. I installed the system 2 days a ago. There are some threads in this forum with the same problem - but it seems there isn’t a clearly reason of this problem.

Abstract of the other theads.

  • Most cases - new installations are affected - latetest version of NC/docker image/Plugin.
  • Perhaps a lanugae problem - spanish version seems to the have same problem.

I played around for hours - no solution.

Peter

Update: I have a similar enviroment like this user:


He found yesterday a solution - he will publish his solutions!

Same here.
I’ve just installed NC (11.0.1) on Ubuntu 16.04 with the web gui and enabled Collabora in the apps section.
No “Office” or “Collabora” icon available and if I try to open a document I get “Access forbidden”.

click on + sign?

For Apache config it seems to be solved:

1. Change `AllowEncodedSlashes On` to `AllowEncodedSlashes NoDecode`

2. Change `ProxyPassMatch "/lool/(.*)/ws$" wss://127.0.0.1:9980/lool/$1/ws` to `ProxyPassMatch "/lool/(.*)/ws$" wss://127.0.0.1:9980/lool/$1/ws nocanon`

Found on Github, provided by caller itself (2nd entry).

For nginx it is still not solved. :frowning:

it seems that the office icon is not available in NC11. I don’t have it either but I have it working. Additional if you are using the latest image beginning of February, you need to fix the alias inside of the image too.

Hej dev0,

sounds great!

Would you please be so kind and share the “how to”. I’ve never modified an image before. And where do I find the mentioned alias and what needs to be changed?

Kind regards
//neph

I posted that here:

Hi!
Are you sure, that your solution is appropiate for this thread? The problem of this thread, for nginx user there is the correct translation of some apache directives is missing.

Hi!

There is an update available for nginx


I tested this fix - but problem still exists.

i don’t know that’s why you should check your docker logs first.

The issue in this thread is that the TC didn’t post very much details of his setup, as nc version, dockerplugin version,
docker logs, the anonymized config of the collabora-webhost-config, etc.

I asked in the metaboard for a pin where user are getting told what details and infos they should add to stop sticking around in the straw.

Me too and it didn’t work for me neither.

Seems to work on Cent OS 7 and apache 2 with the current versions of next cloud and collaboraoffice docker images, though some care is required in setting security permissions. In particular careful check of SELINUX configuration and editing of etc/httpd/conf/httpd.conf is required.

same here.

for me it seams that some changes have been made in that collabora-docker-image, because the same procedure of installing collabora worked a few weeks ago on an identical system :confused:

i have to correct myself, on my site it was related to the BROWSER!

  • Opera, didnt work
  • Firefox, didnt work
  • IE, worked

maybe my experience could help to figure out the problem on your side.

in firefox open the debug console, in most times it will tell you what went wrong.

I had the same issue.
Couldn’t find a fix anywhere, reinstalling and stuff didnt change the problem.

I decided to switch to onlyoffice, having some problems with accessing files from an external storage but in conclusion its not so buggy for me.

Regards

if you run into the mixedencryption-issue i doesn’t make a difference which app you are using.
The big advantage with onlyoffice is you can use it with http only in a restricted LAN where lets encrypt is not working,

@dev0 what do you mean you cant use it with https? :open_mouth: I think im not up to date with this issue…

you can both use with https but the collabora dockerimage is incompatible with http only.