Fehlermeldungen nach Installation von Nextcloud (.ocdata, alte PHP-Version, Referrer-Policy)

Hallo,
ich habe Nextcloud 20.0.1 auf einem Computer mit Ubuntu 20.04 installiert. Webserver ist Nginx, PHP wird in der Version 7.2 (php7.2-fpm als Fastcgi) eingesetzt, Mysql als Datenbank. Die Installation von Nextcloud funktioniert soweit, wirft ein paar Fehlermeldungen aus.

  1. Fehlermeldung bei Cronjobs
    Meldung ist:

Die Ausführung des Cron-Jobs über die Kommandozeile war nicht möglich. Die folgenden technischen Fehler sind dabei aufgetreten:
Ihr Datenverzeichnis ist ungültig. Stellen Sie sicher, dass eine Datei “.ocdata” im Wurzelverzeichnis des data-Verzeichnisses existiert.

Das Root-Verzeichnis des Webservers ist /var/www/nextcloud/. Das Datenverzeichnis ist /media/daten/nextcloud/. Im Datenverzeichnis liegt diese Datei aber in /media/daten/nextcloud/.ocdata:

Auch das nochmalige Ausführen von
sudo -u www-data php7.2 occ files:scan --all
brachte keine Verbesserung.

Was kann hier die Ursache für den Fehler sein?

  1. Fehlermeldung, alte PHP-Version:

Du verwendest derzeit PHP 7.2.34-8+ubuntu20.04.1+deb.sury.org+1. Upgrade Deine PHP-Version, um die Geschwindigkeits- und Sicherheitsupdates zu nutzen, welche von der PHP-Gruppe bereitgestellt werden, sobald diese Deine Distribution unterstützt. …

Gibt es irgendwo eine Anleitung, damit ein Update auf 7.4 funktioniert? Ich hatte letztens ein Downgrade auf 7.1 versucht, das hat Nginx nicht übernommen. In der Nginx-Config steht hier

upstream php-handler {
    server 127.0.0.1:9000;

}

bzw.

fastcgi_split_path_info ^(.+\.php)(/.+)$;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
fastcgi_param HTTPS on;
fastcgi_param modHeadersAvailable true; #Avoid sending the security headers twice
fastcgi_pass php-handler;
fastcgi_read_timeout 300;
  1. Fehlermeldung, Referrer-Policy:

Der “Referrer-Policy” HTTP-Header ist nicht gesetzt auf “no-referrer”, “no-referrer-when-downgrade”, “strict-origin”, “strict-origin-when-cross-origin” oder “same-origin”.

Was muss hier gemacht werden?

Danke für eure Unterstützung!

zur ersten Fehlermeldung:
ist nun doch gelöst, musste noch einen Cronjob anlegen https://docs.nextcloud.com/server/20/admin_manual/configuration_server/background_jobs_configuration.html#cron

zur dritten Fehlermeldung:
habe in die Nginx-Config einfach ein
add_header Referrer-Policy "no-referrer" always;
eingefügt.
Einfach unter

server {
listen 443 ssl;
server_name 192.168.0.2;
ssl on;
ssl_certificate …;
ssl_certificate_key …;

    # Add headers to serve security related headers
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options "noopen";
    add_header X-Permitted-Cross-Domain-Policies "none";
    add_header Referrer-Policy "no-referrer" always;

zumindest ist nun die Fehlermeldung weg. Fehlt nur noch die Aktualisierung der PHP-Version. Gibt es da eine verständliche Anleitung zu, die passen könnte?