Fehlermeldung apacheserver; Hier Zertifikat von IONOS hinerlegen

Hallo zusammen,

ich habe auf meinem PI folgende Verson am laufen:

NextCloudPi version v1.35.0
NextCloudPi image NextCloudPi_03-28-20
distribution Raspbian GNU/Linux 10 \n \l

jetzt habe ich auf IONOS ein Konto und habe hier mir die Zertifikate heruntergeladen (pivate/public) um möchte diese nun auch aktivieren.
Leider habe ich hier das Problem das ich eine Fehlermeldung bekomme:

Sat Apr 24 00:00:10.338469 2021] [ssl:warn] [pid 843:tid 3069764112] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name 2 [Sat Apr 24 00:00:10.338775 2021] [ssl:error] [pid 843:tid 3069764112] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: CN=archlinux / issuer: CN=archlinux / serial: **************************************************** / notbefore: Mar 28 20:04:49 2020 GMT / notafter: Mar 26 20:04:49 2030 GMT] 3 [Sat Apr 24 00:00:10.338801 2021] [ssl:error] [pid 843:tid 3069764112] AH02604: Unable to configure certificate localhost:4443:0 for stapling 4 [Sat Apr 24 00:00:10.340004 2021] [mpm_event:notice] [pid 843:tid 3069764112] AH00489: Apache/2.4.38 (Raspbian) OpenSSL/1.1.1d configured -- resuming normal operations 5 [Sat Apr 24 00:00:10.340041 2021] [core:notice] [pid 843:tid 3069764112] AH00094: Command line: '/usr/sbin/apache2'

Ich sollte dabei vielleicht erwĂ€hnen das ich NUR ĂŒber 443 die NC erreichen kann und ich das auch so weiter betreiben will :wink:

Nun sollte ich in der vhost config den hostnamen eintragen. Leider finde ich keine Möglichkeit unter /etc/apache2/* hier meinen hostnamen einzutragen.

Frage: Suche ich hier an der falschen Stelle oder sollte ich hier eine neue *.conf erstellen?

Ich bin gerade dabei meinen Wissensstand fĂŒr die Nextcloud zu erweitern daher wĂ€re ich ĂŒber jede Hilfe erfreut.

Danke im vorraus :v:t3:

SSL-configs sind oft im Unterordner sites-enabled
 Dort musst du eigentlich auch den Pfad zu dem SSL-Zertifikat eingetragen haben. In der SSL-Config steht dann der ServerName


1 Like

Kurze Frage, welches Zertifikat meinst du? Das von deiner Domain oder das welches du fĂŒr deine Nextcloud auf deinem Server verwenden willst? :thinking:
So wie ich das verstanden habe, ist das Zertifikat an den Server gebunden, der die Seite liefert.
Oder hast du deine Nextcloud auf dem IONOS Server installiert?

Ich fange gerade aber auch erst an. :v:

Hallo @Rookie

Du hast keine echten Nachteile, wenn du Port 80 und 443 an deinen RasPi weiterleitest. Du hast aber einen entscheidenden Vorteil: Du kannst dann nĂ€mlich einfach das eingebaute Script von NCP verwenden, um Let’s Encrypt Zertifakte zu beziehen.

Zu den IONOS Zertifikaten selbst kann ich nur sagen. Falls diese Zertifikate nicht allgemeingĂŒltig fĂŒr deine Domain sind (*.deinedomain.tls), sprich entweder eine andere Subdomain beinhalten, als diejenige, die du auf dem Raspi verwendest oder gar die IONOS Domain beinhalten, wird es so nicht funktionieren.

1 Like

Danke erstmals fĂŒr die BeitrĂ€ge :+1:

@tflidd : Danke fĂŒr den Hinweis. Ich habe mich mittlerweile auch ein bisschen in apache2 eingelesen und bin auch zu dem Ergebnis gekommen. Ich hab hier die Datei “000-default.conf” gefunden in der ich dann den vhost eintragen.

@2ktrouble : Ich habe das Zertifikat von IONOS fĂŒr meine Domain gemeint (sowohl privaten als auch öffentlichen SchlĂŒssel). Der PI mit NC steht bei mir hier brav im Schrank. Auf IONOS habe ich meine Domain sowie einen Server der Anfragen von IPv6 und IPv4 auf meine PI umleitet. Dies habe ich nur weil ich einen Provider habe mit einem Vertrag der DSlite beinhaltet.

@bb77 : Also so wie ich das sehe Port 80 = unverschlĂŒsselt und Port 443 = verschlĂŒsselt ??? Finde hier doch schon einen Unterschied. Aber ich weiß was du meinst :wink:

Also ich habe da nochmals nachgeschaut 
 aber ich sehe da nur meine Domain drin stehen. Ich werde es sehen wenn ich das jetzt in Angriff nehme.

Werde berichten


Hallo zusammen,

also Problem gelöst.
Es gibt 3 Zertifikate die eingebunden werden mĂŒssen:
Intermediate, private-key und öffentlicher-key

Die sollten auch in der richtigen Datei hinterlegt werden (was mein Fehler war).
→ nextcloud.conf

1 Like