Fehlerhafte Integritätsprüfung beim Update auf 28.0.1

Hallo zusammen,

ich habe meine Instanz auf von Hub6 auf 28.0.1 angehoben. Nun habe ich drei Fehler in meiner Systemkonfiguration mit denen ich nichts anfangen kann?

Das System selbst ist eine Debian-VM mit PostgressSQL-Datenbank, und PHP8.2.14.

Hoffe es kann mir hier jemand helfen?

Gruß, paddl

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- core
	- INVALID_HASH
		- core/js/mimetypelist.js
	- EXTRA_FILE
		- core/img/filetypes/dwb.svg
		- core/img/filetypes/drawio.svg

Raw output
==========
Array
(
    [core] => Array
        (
            [INVALID_HASH] => Array
                (
                    [core/js/mimetypelist.js] => Array
                        (
                            [expected] => 550ab566d30693bfa24ec4b15d9df87731ae8a3be8f79dabf94757e5b8b20eec6e4b678f17af1718297f2872f6b04519eeb024d1dff11947f29da431c7f11201
                            [current] => 301654cbbe168b8723530db88fd2e40ad688f4e6b0bdaeade5b4fe34bd94d9d3cfe760821e97dc792e585d4b6ccff838597bfd46466bb07d30ff84df4cb79518
                        )

                )

            [EXTRA_FILE] => Array
                (
                    [core/img/filetypes/dwb.svg] => Array
                        (
                            [expected] => 
                            [current] => 43731dd5f17a048112ea5109b40b02ec019b3ee2324385a0f448e3bd2264cb13dc160ab018d893f92f8e2f168fd09009b51578c8c6b97a02a1617c67ac087701
                        )

                    [core/img/filetypes/drawio.svg] => Array
                        (
                            [expected] => 
                            [current] => 92e0974cf869bf8ab969c3442dc2b80d55fde36441d22924db74916a06b407520aa2a9dc39336f9157195ebede697ffac0e639360879255ab91932d406e1897d
                        )

                )

        )

)

Hallo,

tatsächlich waren dass auch genau die Dateien die bei mir nach dem Upgrade bemängelt wurden.

Das Problem mit der mimetypelist kann man beheben durch:

user@nextcloud:~# sudo rm /var/www/nextcloud/core/js/mimetypelist.js
user@nextcloud:~# sudo wget https://raw.githubusercontent.com/nextcloud/server/master/core/js/mimetypelist.js -P /var/www/nextcloud/core/js/

Die anderen beiden Dateien kann man löschen.

Meine Vermutung ist, dass das drawio-Plugin die mimetypelist anpasst, und “dwb” und “drawio” hinzufügt - ohne die hashes anzupassen.

1 Like

Die unteren beiden Dateien das kann ja mal passieren. Aber das mit der ersten Datei core/js/mimetypelist.js ist schon komisch. Da Hashes meistens eindeutig sind, kann man gut danach im Internet suchen und findet andere Personen mit dem Problem.

301654cbbe168b8723530db88fd2e40ad688f4e6b0bdaeade5b4fe34bd94d9d3cfe760821e97dc792e585d4b6ccff838597bfd46466bb07d30ff84df4cb79518

Passieren darf sowas eigentlich nicht. Komisch, dass es bei genau der Datei auch schon bei anderen Upgrades passiert ist. Vielleicht weiß jemand mehr.

Vielen Dank, das wars :slight_smile: